x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

System freezes when using ATI GPU

When starting the game built in Development or Shipping configuration on a Linux PC using a ATI graphics adapter the entire system freezes some seconds after the application was launched. When running with a nVidia card the game works fine. When starting a Debug build on the ATI machine I get the attached stack trace. Also you'll find the log file of this start.

I guess this issue might be related to the preceding questions:

It would be great to get any recommendations how to solve or work around this issue. Besides this I'll try to figure out if this can be reproduced with proprietary drivers and report on it.

Product Version: UE 4.16
Tags:
stack-trace.txt (2.7 kB)
log.txt (78.9 kB)
more ▼

asked Aug 25 '17 at 01:08 PM in Linux

avatar image

j.mueller RFG
304 3 10 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

See this case. https://bugs.freedesktop.org/show_bug.cgi?id=101977#c15 and also the latest answer from Timoo, who also made a commit to 17.1
Either would work. Since you are on 4.16, go ahead and try to locate libelf.so like one of these for example:

LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libelf.so ./UE4Editor

LD_PRELOAD='/usr/lib/x86_64-linux-gnu/libelf.so.1' ./UE4Editor

Just use this to start your editor, and you should be fine. Read about why this works near the end of the case i linked if you would like to know.
Also the freeze shouldn't happen, try getting most recent mesa drivers, 17.3. Think about it if you want to try, and if so add the ppa as described, followed by sudo apt-get update. https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers.

more ▼

answered Aug 30 '17 at 08:57 PM

avatar image

Complex
13 2 5

avatar image j.mueller RFG Sep 02 '17 at 04:03 PM

Thanks a lot for this recommendation. Sadly it seems not to work for the issue I am dealing with. The game is still crashing the system shortly after it is launched. Since I also need to set LD_LIBRARY_PATH I'm using export to for setting these env vars prior to calling the game binary, but this should not make a difference from the game process perspective.

The mesa version I'm running on is mesa 17.0.7 (Ubuntu 16.04.1) and I can't get a newer version from the package repository, so I will probably have to wait for the update to arrive.

avatar image remma12 Sep 06 '17 at 11:53 AM

I'm running 17.1.8-1 (on Arch) similar issue. R9 280X Can now launch the editor (thanks to Complex and the LD_PRELOAD fix) but if I hit Play the system is locked though interestingly sound still plays perfectly which seems to indicate it is just graphics

avatar image gadLinux Nov 26 '17 at 10:19 AM

For me too. It just hangs linux complely

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question