x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Wheeled vehicle tips over in game mode

Hi, I followed the Vehicle Art Setup and Vehicle User Guide in the Unreal documentation. I exported my vehicle from Blender and set it up in Unreal with a physics asset, anim blueprint, etc. However when I go into game mode, the vehicle just tips over immediately. If I'm unlucky, it even falls over side ways. I double checked the center of mass to make sure nothing odd is going on, but the issue still persists. The center of mass is visible in the image below. alt text

The physics asset looks mostly fine too. The wheels are kinematic as instructed by the guide, the bones are properly oriented. The wheel animations work perfectly in game mode in response to my input. alt text

Clicking the simulate button in the physics asset produces this weird behavior. The wheels just vanish. I don't think it's supposed to do that. Setting the wheels to not be kinematic stops this particular issue. alt text

I tried with a different vehicle model. That one tips over backwards instead. Is there something I'm missing?

Product Version: UE 4.17
Tags:
ue-car-lean.png (416.0 kB)
ue-car-phat.png (501.8 kB)
more ▼

asked Aug 25 '17 at 04:55 PM in Using UE4

avatar image

khalibloo
46 3 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

https://www.youtube.com/watch?v=zxmpqShj-dM Good luck ;) This one should work.

more ▼

answered Oct 20 '17 at 02:09 PM

avatar image

Ligazetom
82 8 13 16

avatar image khalibloo Nov 20 '17 at 08:21 AM

Hi, thanks for the effort. I've followed that several times over. I don't see anything I could do differently. I've re-rigged and re-exported using different export settings from different tutorials. I've used 3 different engine versions including the newest (4.18).

I'm inclined to think my issues are not from the export process though. My vehicle wheels spin on the right axis and steer correctly. The scale is right too. I think if I had a problem with orientation, the wheel animations would have been broken.

I think it's likely something to do with the physics asset. The vehicles just won't stay upright. When I set the wheels to kinematic and simulate, they immediately disappear. I tried shrinking the body primitive so that there's no overlap. Still didn't help. Can I send you a minimal project so you can have a look?

avatar image Zedokus Nov 20 '17 at 08:54 AM

start game, open console ~, type ShowDebug VEHICLE, check if wheel's size or body axis is wrong.

avatar image khalibloo Nov 20 '17 at 09:06 AM

Wow, that was a very helpful trick. At first, nothing stood out to me, except that I couldn't see the wheels like you mentioned. Then I noticed they're all at the vehicle's origin! that's why the vehicle tips over, it's essentially a unicycle. In the wheel setup, I assumed it would use the wheel bone positions automatically to position the physics wheels. I'll try manually offsetting them to see if that fixes my issues. If it does, I'll dedicate my weekends to memorizing these unreal secret commands :D

avatar image khalibloo Nov 20 '17 at 09:21 AM

Yes! Manually adding the wheel offsets worked. Thank you very much. I can drive my vehicles at last. I still have no idea why it wasn't using the bone positions even though I'd clearly specified my wheel bones. I'm curious to know if there's a reason for that.

avatar image Josehfortes Mar 24 '19 at 02:15 PM

How can you do that? I have same problem!

avatar image khalibloo Mar 24 '19 at 06:43 PM

I fixed it by adjusting the positions (additional offsets) of the wheels in the Vehicle Movement component > Vehicle Setup section > Wheel Setups option. I copied their positions from blender and converted the units from m (blender units) to cm (ue4 default units).

avatar image Josehfortes Mar 24 '19 at 07:12 PM

Works for me too! Thanks very muchh!

But you understood the reason for that occurs with blender exports?

avatar image Ligazetom Mar 24 '19 at 07:18 PM

I believe it has something to do with scale. It is always something like this.

avatar image khalibloo Mar 24 '19 at 07:28 PM

Glad to hear! Congrats! It's quite a stressful bug, this one.

I never quite figured out the reason this happens. I'm guessing it may have something to do with the way blender handles bone hierarchies in fbx exports.

From what I read somewhere, many 3D apps use joints instead of bones. So the last bone in a chain ends in a joint. Blender uses bones, and the last bone does not end in a joint (eg, the fingertip or the wheels in this case). As a result, the end of the chain is lost. A wheel bone can also be lost in this way, I think.

This is the closest suspect I have at this time. But it does not explain why the model itself and the physics skeletons are unaffected by this bug. Perhaps the vehicle movement component uses a different fbx pipeline in unreal. Who knows...

Edit: Good old blender scale :D I wouldn't be surprised either if that's the culprit all along.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question