x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnimSequenceBase.cpp randomly causes assertion

Hi!

When testing my game it crashes randomly when I use "simple move to" node. The error is:

 D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.2\Engine\Source\Runtime\Engine\Private\Animation\AnimSequenceBase.cpp(242): Assertion failed: bPlayingBackwards ? (CurrentPosition <= PreviousPosition) : (CurrentPosition >= PreviousPosition)

I've tried to reimport the models and animations which didn't help. This happens on multiple characters and moving them might work multiple times and then suddenly crash.

I was able to reproduce this issue in a new project with a simple blueprint:alt text

Branch: Binary, using launcher

Build version: 4.2.1-2101290

Thanks!

Product Version: Not Selected
Tags:
animcrash.png (177.1 kB)
more ▼

asked Jul 16 '14 at 07:02 AM in Bug Reports

avatar image

Fervensmiber
119 8 13 18

avatar image [Epic] Gribbs ♦♦ STAFF Jul 17 '14 at 06:18 PM

Howdy Fervensmiber,

Thank you for your bug report. I have attempted to reproduce your bug and have been unsuccessful. I have created a Character Blueprint and have set it up exactly as you have shown in the photo. I haven't seen any crashing when placing the blueprint into the level and/or moving it around in the level.

If there is any additional information on how I may be setting this up wrong or any steps that are not included, please do let me know so i can attempt another reproduction.

Thanks and have a great day!

avatar image Fervensmiber Jul 18 '14 at 06:42 AM

Hello Sean and thanks for looking into this! I used Pawn instead of Character, but the problem might be caused by the assets we are using. I sent you a repro project as a private message through forums. Could you check it out? It contains only the blueprint that causes the issue. We have encountered the same error with multiple assets, but if you can find fault in this one I think we can help ourselves from there. Thanks!

avatar image Slavq Jul 05 '15 at 04:33 PM

I have exactly the same error, and it also crashes randomly. I'm on 4.8.1, is it broken again? (I can't apply this workaround with setting SetPosition to 0.f. after playing animation, because i use animation blueprint, not Play Animation nodes)

PS. When this crash happens (random), it seems like it's always right after character is reaching his destination point, after performing Simple Move to Location.

Edit: I've managed to work around this bug by delaying any actions taken AFTER reaching destination point by ~0.3s in my function. Maybe it's because previously playing animation was somehow not fully blended yet and this causes the error? Well anyway, i've decided to give it some time, and waiting 0.3 seconds before playing any other animation fixed it - but the bug is still there.

Edit2: Just noticed that my workaround works only in one case, the bug still crashes my game...

Edit3: THIS thread is probably the same bug, i have very similar setup

Edit4: As OP said in thread linked above, the bug appears only when the new animation is shorter than the previous one! Just tested it.

avatar image Matt.Williams Jul 08 '15 at 09:27 PM

Hi Slavq,

In cases like this where your crash may have the same repro steps, we would appreciate it if you made one new answerhub post instead of reviving old posts. While the repro may be the same, the cause could be new. Please make a new post.

-Matt W.

avatar image Slavq Jul 09 '15 at 12:23 AM

OK, just did it with new repro demo project, HERE

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Howdy Fervensmiber,

I received the files through the private message, thank you for that. I was able to see the crash on my end and I have proceeded to write a bug report for the issue. Please let us know if anything further develops.

Thanks again and have a great day!

more ▼

answered Jul 18 '14 at 06:38 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

avatar image Fervensmiber Jul 21 '14 at 06:01 AM

Hi Sean and thanks for reporting this forward. Were you able to investigate what might be causing this so we could workaround it, instead of disabling all of our animations?

avatar image nikolobin STAFF Jul 22 '14 at 03:08 AM

I fixed this in latest, but to work around for you, right after you play animation, make sure to set SetPosition to 0.f. There was a bug where position isn't reset.

Thanks,

--Lina,

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question