x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG crashes Android

Hey,

I'm getting a crash on Android when using UMG to move widgets.

I multiple animations that I try and play, and each one crashes the mobile when they start to play. If I remove everything from the animation (so it basically tries to play an empty animation) then everything works ok.

This is the call stack. Any ideas how to fix this?

 D/UE4: Assertion failed: Pair != nullptr [File:Runtime/Core/Public/Containers/Map.h] [Line: 444] 
 D/UE4: libUE4.so!FDebug::LogAssertFailedMessage(char const*, char const*, int, wchar_t const*, ...) 
 D/UE4: libUE4.so!FMovieSceneRootEvaluationTemplateInstance::CallSetupTearDown(IMovieScenePlayer&, FDelayedPreAnimatedStateRestore*) 
 D/UE4: libUE4.so!FMovieSceneRootEvaluationTemplateInstance::Evaluate(FMovieSceneContext, IMovieScenePlayer&, FMovieSceneSequenceID) 
 D/UE4: libUE4.so!UUMGSequencePlayer::PlayInternal(double, double, double, double, int, EUMGSequencePlayMode::Type, float) 
 D/UE4: libUE4.so!UUserWidget::PlayAnimation(UWidgetAnimation*, float, int, EUMGSequencePlayMode::Type, float) 
 D/UE4: libUE4.so!UBP_MainMenu_C__pf2028121400::bpf__ExecuteUbergraph_BP_MainMenu__pf_5(int) 
 D/UE4: libUE4.so!UUserWidget::execOnAnimationFinished(FFrame&, void*) 
 D/UE4: libUE4.so!UFunction::Invoke(UObject*, FFrame&, void*) 
 D/UE4: libUE4.so!UObject::ProcessEvent(UFunction*, void*) 
 D/UE4: libUE4.so!UUserWidget::OnAnimationFinished(UWidgetAnimation const*) 
 D/UE4: libUE4.so!UUserWidget::OnAnimationFinishedPlaying(UUMGSequencePlayer&) 
 D/UE4: libUE4.so!TBaseUObjectMethodDelegateInstance<false, UUserWidget, void (UUMGSequencePlayer&)>::ExecuteIfSafe(UUMGSequencePlayer&) const 
 D/UE4: libUE4.so!TBaseMulticastDelegate<void, UUMGSequencePlayer&>::Broadcast(UUMGSequencePlayer&) const 
 D/UE4: libUE4.so!UUMGSequencePlayer::Tick(float) 
 D/UE4: libUE4.so!UUserWidget::TickActionsAndAnimation(FGeometry const&, float) 
 D/UE4: libUE4.so!UUserWidget::NativeTick(FGeometry const&, float) 
 D/UE4: libUE4.so!SObjectWidget::Tick(FGeometry const&, double, float) 

Cheers, Chris

Product Version: UE 4.17
Tags:
more ▼

asked Aug 27 '17 at 03:06 PM in Bug Reports

avatar image

Piranhi
61 2 7 11

avatar image Hyunwoo Kang Aug 29 '17 at 05:53 AM

I have same problem. :(
build ver: UE4.17.1 build setting: Blueprint Nativization Method: Inclusive error point: Play UMG Animation in construct event.

avatar image Piranhi Aug 29 '17 at 09:57 AM

Glad it's not just me.

I've tried everything I can think of to fix the issue. I don't think this happened with 4.17, but it definitely does with 4.17.1.

avatar image Piranhi Aug 31 '17 at 07:26 AM

Hey - Any update from Epic Staff? This is stopping me from publishing my game :(

Cheers, Chris

avatar image Piranhi Sep 08 '17 at 08:23 AM

Hey - It's been over 3 weeks and still no reply :( This is the only bug preventing me from publishing. Any reply would be really appreciated

avatar image Thomas G ♦♦ STAFF Sep 11 '17 at 05:35 PM

Hello Piranhi,

I was unable to reproduce the issue you are experiencing on our end. I have a couple of questions about your issue to help me investigate further.

  1. Can you reproduce this issue in a new project?

  2. If so could you provide a detailed list of steps, so that I can reproduce this issue?

  3. How many elements are you controlling through each animation?

  4. How are you calling the animation to play? Through the widget, or through another blueprint?

Thanks!

avatar image Piranhi Sep 21 '17 at 08:30 PM

Hey Thomas,

4.18 seems to have fixed the issue. It's added a few weird UMG bugs, but at least the game runs now.

Just to quickly answer some of your questions:

How many elements are you controlling through each animation? - Between 1 and 10

How are you calling the animation to play? Through the widget, or through another blueprint? - Through blueprints in the widget.

Cheers, Chris

avatar image Thomas G ♦♦ STAFF Sep 27 '17 at 06:02 PM

Hello again Chris,

I am still unable to reproduce the issue you are experiencing. Were you able to reproduce the crash in a new project?

avatar image 7ortis7 Sep 02 '17 at 02:23 PM

Same problem here

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks!

more ▼

answered Oct 05 '17 at 01:58 PM

avatar image

Thomas G ♦♦ STAFF
7k 64 4 54

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question