x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

4.17.1 - iOS 11 beta 7 ipa install fails, Couldn't start AFC service

This occurs on Windows 10 UE 4.17.1 with a connected iPad Air 2 and iPhone 6s running iOS 11 beta 7 with a remote Macbook Air with macOS High Sierra 10.13 beta setup correctly. Certs and provisioning are setup correctly and process without issue. This is using the Launch button to create and install the build. Build completes without issue. IPA file generated and transferred to device without issue on iPad but failed to transfer on iPhone. The log does not provide more info on what the error could be.

Trying to install ipa file through Windows 10 iTunes 12.6.2.20 and through macOS High Sierra 10.13 iTunes 12.7.0.48 also fails. iTunes complains that

The project only includes default content from a blank mobile project template with one default level. The ARKit plugin is the only plugin enabled.

"the app was not installed on the iPhone/iPad because it requires a newer version of iOS"

. Currently using iOS 11 beta 7 (15A5362a) on both devices.

Not sure if this is a bug or an oversight. Any help would be appreciated.


iPad Log

On the iPad, install stops at PreflightingApplication 30%. Here is the relevant portion of the log.

LogPlayLevel: IPhonePackager: Finished repackaging into 122.22 MB IPA, written to 'E:\Unreal4\Binaries\IOS\TelegramAR_Unreal4.ipa' (took 2.70 s for all steps)
LogPlayLevel: CommandUtils.Run: Run: Took 2.7954831s to run IPhonePackager.exe, ExitCode=0
LogPlayLevel: Project.Package: ********** PACKAGE COMMAND COMPLETED **********
LogPlayLevel: Project.Deploy: ********** DEPLOY COMMAND STARTED **********
LogPlayLevel: CommandUtils.Run: Run: D:\Program Files\Epic Games\UE_4.17\Engine\Binaries\DotNET\IOS\DeploymentServer.exe Install -ipa "E:\Unreal4\Binaries\IOS\TelegramAR_Unreal4.ipa" -device All_iOS_On_ASUSG750JX -additionalcommandline "-SessionId=4889D4604AFEBB4F2A688D8A916D6C6D -SessionOwner="User" -SessionNam
e="Launch On Device" "
LogPlayLevel: DeploymentServer: [deploy] Created deployment server.
LogPlayLevel: DeploymentServer: [DD] Trying to connect to mobile device running iOS ...
LogPlayLevel: DeploymentServer: [DD] Mobile Device 'iPad' connected
LogPlayLevel: DeploymentServer: Device 'iPad' with id g799edcccd1be463g of type iPad5,3 is being checked against All_iOS_On_ASUSG750JX.
LogPlayLevel: DeploymentServer: [DD] Transferring IPA to device 'iPad' ...
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 6144 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 11264 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 16384 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 21504 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 26624 KB of 125148 KB
LogPlayLevel: DeploymentServer: Connect: Couldn't Start AFC service
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 31744 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 36864 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 41984 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 46080 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 51200 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 56320 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 61440 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 66560 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 71680 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 76800 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 81920 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 87040 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 91136 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 96256 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 101376 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 106496 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 111616 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 116736 KB of 125148 KB
LogPlayLevel: DeploymentServer: [DD]  ... Transferred 121856 KB of 125148 KB
LogPlayLevel: DeploymentServer:  ... Finished copying to 'PublicStaging/TelegramAR_Unreal4.ipa' in 4.90 s
LogPlayLevel: DeploymentServer: [DD] Installing IPA on device 'iPad' ...
LogPlayLevel: DeploymentServer: [DD]  ... Install is 5% complete at phase 'CreatingStagingDirectory'
LogPlayLevel: DeploymentServer: [DD]  ... Install is 15% complete at phase 'ExtractingPackage'
LogPlayLevel: DeploymentServer: [DD]  ... Install is 20% complete at phase 'InspectingPackage'
LogPlayLevel: DeploymentServer: [DD]  ... Install is 20% complete at phase 'TakingInstallLock'
LogPlayLevel: DeploymentServer: [DD]  ... Install is 30% complete at phase 'PreflightingApplication'
LogPlayLevel: DeploymentServer: Install \ Update of "TelegramAR_Unreal4.ipa" failed with Unknown error 0xE800007E in 3.45 seconds
LogPlayLevel: DeploymentServer: [DD]
LogPlayLevel: DeploymentServer: Connect: Couldn't Start AFC service
LogPlayLevel: DeploymentServer: Connect: Couldn't Start AFC service
LogPlayLevel: DeploymentServer: Exiting.
LogPlayLevel: CommandUtils.Run: Run: Took 11.5496989s to run DeploymentServer.exe, ExitCode=1
LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.CommandUtils+CommandFailedException: Command failed (Result:1): D:\Program Files\Epic Games\UE_4.17\Engine\Binaries\DotNET\IOS\DeploymentServer.exe Install -ipa "E:\Unreal4\Binaries\IOS\TelegramAR_Unreal4.ipa" -device All
_iOS_On_ASUSG750JX -additionalcommandline "-SessionId=4889D4604AFEBB4F2A688D8A916D6C6D -SessionOwner="User" -SessionName="Launch On Device" ". See logfile for details: 'DeploymentServer-2017.08.27-15.27.35.txt'
LogPlayLevel:    at AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, String Logfile, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary`2 EnvVars, SpewFilterCallbackType SpewFilterCallback)
LogPlayLevel:    at AutomationTool.CommandUtils.RunAndLog(CommandEnvironment Env, String App, String CommandLine, String LogName, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary`2 EnvVars, SpewFilterCallbackType SpewFilterCallback)
LogPlayLevel:    at IOSPlatform.Deploy(ProjectParams Params, DeploymentContext SC)
LogPlayLevel:    at Project.Deploy(ProjectParams Params)
LogPlayLevel:    at BuildCookRun.DoBuildCookRun(ProjectParams Params)
LogPlayLevel:    at BuildCookRun.ExecuteBuild()
LogPlayLevel:    at AutomationTool.BuildCommand.Execute()
LogPlayLevel:    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, Dictionary`2 Commands)
LogPlayLevel:    at AutomationTool.Automation.Process(String[] Arguments)
LogPlayLevel:    at AutomationTool.Program.MainProc(Object Param)
LogPlayLevel:    at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
LogPlayLevel:    at AutomationTool.Program.Main()
LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 18.766314
LogPlayLevel: BUILD FAILED
PackagingResults: Error: Deployment failed! Unknown Error


iPhone Log

On the iPhone, deployment stops after connecting to device. Here is the relevant portion of the log.

LogPlayLevel: IPhonePackager: Finished repackaging into 122.22 MB IPA, written to 'E:\Unreal4\Binaries\IOS\TelegramAR_Unreal4.ipa' (took 2.72 s for all steps)
LogPlayLevel: CommandUtils.Run: Run: Took 2.8095046s to run IPhonePackager.exe, ExitCode=0
LogPlayLevel: Project.Package: ********** PACKAGE COMMAND COMPLETED **********
LogPlayLevel: Project.Deploy: ********** DEPLOY COMMAND STARTED **********
LogPlayLevel: CommandUtils.Run: Run: D:\Program Files\Epic Games\UE_4.17\Engine\Binaries\DotNET\IOS\DeploymentServer.exe Install -ipa "E:\Unreal4\Binaries\IOS\TelegramAR_Unreal4.ipa" -device All_iOS_On_ASUSG750JX -additionalcommandline "-SessionId=41B43F51441C36BF6094E9866F77C4B2 -SessionOwner="User" -SessionNam
e="Launch On Device" "
LogPlayLevel: DeploymentServer: [deploy] Created deployment server.
LogPlayLevel: DeploymentServer: [DD] Trying to connect to mobile device running iOS ...
LogPlayLevel: DeploymentServer: Connect: Couldn't Start AFC service
LogPlayLevel: DeploymentServer: [DD] Mobile Device 'iPhone' connected
LogPlayLevel: DeploymentServer: Connect: Couldn't Start AFC service
LogPlayLevel: DeploymentServer: Exiting.
LogPlayLevel: CommandUtils.Run: Run: Took 2.8745396s to run DeploymentServer.exe, ExitCode=1
LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.CommandUtils+CommandFailedException: Command failed (Result:1): D:\Program Files\Epic Games\UE_4.17\Engine\Binaries\DotNET\IOS\DeploymentServer.exe Install -ipa "E:\Unreal4\Binaries\IOS\TelegramAR_Unreal4.ipa" -device All
_iOS_On_ASUSG750JX -additionalcommandline "-SessionId=41B43F51441C36BF6094E9866F77C4B2 -SessionOwner="User" -SessionName="Launch On Device" ". See logfile for details: 'DeploymentServer-2017.08.27-15.53.40.txt'
LogPlayLevel:    at AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, String Logfile, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary`2 EnvVars, SpewFilterCallbackType SpewFilterCallback)
LogPlayLevel:    at AutomationTool.CommandUtils.RunAndLog(CommandEnvironment Env, String App, String CommandLine, String LogName, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary`2 EnvVars, SpewFilterCallbackType SpewFilterCallback)
LogPlayLevel:    at IOSPlatform.Deploy(ProjectParams Params, DeploymentContext SC)
LogPlayLevel:    at Project.Deploy(ProjectParams Params)
LogPlayLevel:    at BuildCookRun.DoBuildCookRun(ProjectParams Params)
LogPlayLevel:    at BuildCookRun.ExecuteBuild()
LogPlayLevel:    at AutomationTool.BuildCommand.Execute()
LogPlayLevel:    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, Dictionary`2 Commands)
LogPlayLevel:    at AutomationTool.Automation.Process(String[] Arguments)
LogPlayLevel:    at AutomationTool.Program.MainProc(Object Param)
LogPlayLevel:    at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
LogPlayLevel:    at AutomationTool.Program.Main()
LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 11.262039
LogPlayLevel: BUILD FAILED
PackagingResults: Error: Deployment failed! Unknown Error

Product Version: UE 4.17
Tags:
more ▼

asked Aug 30 '17 at 01:14 PM in Packaging & Deployment

avatar image

s1ntr0n
11 1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Since no one answered I would like to comment about this since we had a similar issue believe it or not choosing ios 9 as the minimum required version will fix the issue Project settings-->ios-->os info choose 9 as minimum version Choosing 10 will cause this issue even if you are running ios 11 !

Thanks

more ▼

answered Nov 23 '17 at 02:45 PM

avatar image

NullTechs
6 1

avatar image marschoom Jun 16 '18 at 03:11 PM

2018 but I still need to run 4.15.x or 4.16.x due to some unsolved UE OpenGL clipping glitch and THANK YOU this worked!! Along with running XCode 8.3.3 on an iPad Air 1st Gen @iOS 11.3.1.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question