x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

No dynamic/self shadows in 4.16/4.17

2017/9/20 Sorry to bump this again. Could someone just tell me if they're not seeing this issue? I tried deleting the Engine/DerivedDataCache folder but that didn't fix the shadows.


The screenshots I posted below are with everything at default. I literally created a new 3rd person template in each case and took a screenshot without changing anything (except for the Editor camera just so I could show the shadow, and lack thereof).

Update:

3rd person character casts shadows in a brand new 4.15 3rd person template (all settings default). alt text

3rd person character DOES NOT cast shadows in a brand new 4.16 and 4.17 3rd person template (all settings default).

alt text

Initially, I posted the following issue about a skeletal mesh not casting self shadows:

The character in question has 4 materials, one for hair, face, torso, legs. I double-checked that each material has cast shadow checked. I tried mucking with the shadow bias on a spot light that I use to check the shadows.

Edit: Even if I set all the materials to the same, all non-contiguous areas fail to receive the shadow.

I mocked up a static mesh and stuck it in the level. The same issue occurs here. alt text

Product Version: UE 4.17
Tags:
badshad.png (286.4 kB)
shad.png (186.8 kB)
noshad.png (74.6 kB)
more ▼

asked Aug 28 '17 at 08:33 AM in Using UE4

avatar image

kusokuso1
352 35 36 56

avatar image Greywacke Aug 28 '17 at 10:14 AM

A couple of questions: Have you tried building the lighting and is the lighting set to static, stationary or movable? What happens if you set the materials to two-sided? (on the off chance that this is some kind of normals/ back face issue)

avatar image kusokuso1 Aug 29 '17 at 09:17 AM

Hey Greywacke,

Thanks a lot for the help. I just now tried building lighting and noticed no change. I then cranked the lighting quality up from preview (default), to high > Built lighting only and still noticed no change.

I'm testing this out in a 3rd person template. Made no changes to the skylight and directional light source, just left'em at default. The spot light I'm using was left at default (static?). I tried setting it to Stationary and Movable but noticed no change.

All character materials are basically default. A few of them have normals and texture masks, but it's nothing fancy. I tried setting all of the materials to Two sided but it didn't seem to make a difference. The character has a physics asset but I didn't make a physics body that would match the shape of the hair (that would take at least 15 different physics bodies to accomplish).

avatar image kusokuso1 Aug 30 '17 at 06:10 AM

Update: I've got UE4 installed on a Japanese Windows 7 64bit Enterprise. Might that have something to do with why no one else is seeing these issues?

I'm using a GTX 670 with the latest drivers installed clean after having DDU'd the old ones in safe mode. Is it possible 670s don't support these kinds of shadows? I checked it on my computer at home, with a slightly different static mesh, and had no problem with shadows. Material complexity was the same for both the bad one I ss'd and the mesh I tried at home.

avatar image TankbusterGames Nov 11 '17 at 12:17 AM

I got tricked by this, too. Easy solution:

Check your Settings -> Engine Scalability Settings -> Shadows is set to high or better hope this works for you as well

avatar image kusokuso1 Nov 13 '17 at 07:15 AM

@TankbusterGames

Thanks a lot for the help, and sorry for the laggy reply. Could you change your comment into an answer? It worked!

avatar image TankbusterGames Nov 25 '17 at 04:05 AM

"Request method not allowed" i can't do that ^^

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question