x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Importing as a skeletal mesh changes the normals or smoothing of objects

Hey,

There seems to be something wrong with the import process where face normals or smoothing groups are being affected by importing a mesh as a skeleton. Is there any way this can be corrected and solved?

1) Shows the mesh imported as a static mesh and the face normal/smoothing work correctly with the normal map

2) Shows the mesh imported as a skeletal mesh with no skeleton exported with the mesh from 3ds max

3) Shows the mesh imported as a skeletal mesh with a skeleton and morph targets applied from 3ds max

Thanks for any help.

Dan.

alt text

Product Version: UE 4.16
Tags:
smoothingissue.jpg (750.5 kB)
more ▼

asked Aug 30 '17 at 08:31 AM in Rendering

avatar image

Dan0z0
28 7 12 14

avatar image Dan0z0 Jan 05 '18 at 11:59 AM

Hi, I would be really grateful for some advice.

avatar image Pir Mar 18 '18 at 12:12 AM
avatar image Dan0z0 Oct 03 '18 at 03:08 PM

Did you ever get to the bottom of this?

avatar image Taberu Sep 25 '18 at 11:54 PM

Anything? Anyone? I imported one model, both, as a static mesh, and as a rigged skeletal mesh. Skeletal mesh seems to have some weird problems. The issue is well described above in the question and no answer for such a long time? What's the workaround?

avatar image aydincan Sep 26 '18 at 11:24 AM

Have the same issue, trying to find a solution...

avatar image Taberu Sep 26 '18 at 01:47 PM

I forgot to mention I'm working currently on 4.19. Is it fixed on 4.20?

avatar image Dan0z0 Oct 03 '18 at 03:07 PM

Nope, Ive tested on this version.

avatar image Taberu Sep 26 '18 at 05:57 PM

Check out my answer guys! Hope it works for you too, let me know because I could forget about something. If so, I will correct the post.

avatar image aydincan Sep 27 '18 at 01:48 PM

Hey thank you very much! I was using maya but tried this in blender and it worked. Now have to figure out how to do it in Maya. I'll keep here posted.

avatar image Dan0z0 Oct 03 '18 at 03:03 PM

Found some more information, another person with the same issue. https://polycount.com/discussion/comment/2654381#Comment_2654381

avatar image MarkSB Oct 11 '18 at 05:37 PM

I'm running into this same issue in Maya2016 and UE4.2.1. No matter what we do any custom normals are blown and recalculated whenever the mesh is a skeletal mesh. If we unbind skin and export it as a static mesh with custom normals it works fine.

It seems like a bug, but I'm not sure if it's in the FBX exporter or if it's the Importer in Unreal!?

It would be great to have some devs look into this and get it working.

avatar image Dan0z0 Nov 12 '18 at 05:42 PM

I've done some more research into this issue and have found that this problem seems to be on unreals end. Please look at my images. When importing a box as a static mesh vertex normals look correct and normal. In a flat side view you can see that the vert normals on each vert line up and look consistent. When importing as a skeletal mesh the vert normals visibly shift direction and no longer line up and don't look consistent. The vert normals on the skeletal mesh should look the same as static mesh but they don't. If I import the skeletal mesh but un tick the skeletal mesh option the mesh imports correctly, this makes me think this is not an issue with 3dsmax.

Using import normals on both meshes - Using anything else for a normal workflow does not work

alt text

vertnormals-01.jpg (472.0 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Ive had the same problem for a while now BUT i think i've found a fix.

Im a Maya user, so when im Exporting an FBX for a skinned asset, be sure to have triangulated on and smoothing groups. ( as mentioned above posts ) but in Unreal when the import Box comes up look for " Normal Import Method " - change it to " Import Normals" ( which will read the normals from the imported FBX ) I think by default its set to " Compute Normals " which will let Unreal make its own Normals up ( which is why they look crap on import )

This has sorted my problems, hopefully it will help you too. GoodLuck!

more ▼

answered Apr 11 '19 at 01:08 PM

avatar image

ssj_shawza
6

avatar image Pixelsmuggler Jun 01 '19 at 10:47 AM

Thank you so much for finding this! I would vote for having that setting as default. I assume most artists are very aware of their normals and want them to look the same as in DCC.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Guys, I probably found out what's the case! It's easy to fix!

I always ignored the error message when importing any FBX file, because it was always there and it didn't do anything. Here is the message:

No smoothing group information was found in this FBX scene. Please make sure to enable the 'Export Smoothing Groups' option in the FBX Exporter plug-in before exporting the file. Even for tools that don't support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.

Well, it tells the exact problem we have. I'm using Blender so I'm sorry for not delivering the answer for 3d Max. I believe you will find it in your program too!

So, if you use Blender, when exporting FBX file, there are settings which looks like that:

alt text

Just change "Smoothing" from "Normals only", to "Face" (or "Edge" if you need).

I hope it will fix it for you. Let me know!

normals.png (16.6 kB)
more ▼

answered Sep 26 '18 at 05:54 PM

avatar image

Taberu
186 4 10 16

avatar image Dan0z0 Oct 03 '18 at 03:00 PM

Hey, Ive looked into the FBX exporter in 3ds max and the only option for controlling smoothing is to export with "smoothing groups". Its worth noting that do not get these import messages saying "No smoothing group information was found".

avatar image Taberu Oct 03 '18 at 04:41 PM

Did it help you then? Btw. you can always export to FBX/obj and generate smoothing groups in Blender! Blender is a free tool. I know it would be annoying as a workflow but that's a working solution for now. Better if you find how to generate smoothing groups in 3D Max, for sure. Good luck.

avatar image Dan0z0 Oct 04 '18 at 12:19 PM

Thanks for the reply. The setting export with smoothing groups has always been set on as thats always how you should export from max (so made no change for me). That is an option (blender), but to switch at this stage would be very difficult, we have morph targets set up and i think it would be a massive pain.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I run into the same issue in Maya and Max, even with the smoothing group option checked on in the FBX export settings. We've tried it with newer and older versions of FBX and we get the same results each time.

Using blender isn't an option for us, I really wish we could get this fixed we have some very ugly seams that don't need to be there.

more ▼

answered Nov 13 '18 at 03:30 PM

avatar image

MarkSB
1 1

avatar image Nanoblubb Feb 20 '19 at 05:15 PM

Hello Folks, checking smoothing groups and triangulate mesh works for me. Reason for that is, that the triangulation (and with that the smoothing) differ in unreal to other aplications.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question