x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

why does static mesh with vertex color look torn/shredded?

Hello!

i have a model for a static mesh with vertex color in blender. in blender the model looks fine but when i import it in ue4 it somehow looks torn or shredde. seems like all the dark areas are missing in ue4. how could i resolve that issue? pictures below for clarification. first is blender, second is ue4.

Thanks,

wambo

alt textalt text

Product Version: UE older version
Tags:
blender-vert.jpg (176.8 kB)
ue4-vert.jpg (89.6 kB)
more ▼

asked Aug 30 '17 at 08:50 AM in Using UE4

avatar image

wambo0402
12 4 3 5

avatar image Iotti Aug 30 '17 at 03:09 PM

The first picture seems to be normal inverted. But since it is ok on Blender, that might be an export isso. What format are you exporting? Did you tried to import it again in another platform?

avatar image wambo0402 Sep 03 '17 at 05:12 PM

the first picture is in blender. and not like the original model, but i could live with this. i exported as .fbx. what do you mean "normal inverted" how could i de-invert? sorry for my asking but i'm very new to this. here is a link to the original model: http://imgur.com/a/ReIcN ...no black or missing triangles there

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Got it!

I have selected the model in blender, changed to from object to edit mode, then pressed ctrl + n and. after that on the lower left hand side appeared "Make Normals Consistent" with a checkbox "Inside". clicked that, exported as fbx, imported in ue4 and everything looks fine.

Thank you for your help!

alt text

normals-cons.jpg (63.1 kB)
more ▼

answered Sep 04 '17 at 08:20 AM

avatar image

wambo0402
12 4 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Looks like some of your tris have inverted normals like lotti already mentioned, can you select your model in Blender, go into Edit Mode, select everything with hotkey A, then use ctrl + N, to recalculate normals. If that doesn't work, please upload a screenshot with your export settings in Blender and Import settings in Unreal.

more ▼

answered Sep 03 '17 at 06:52 PM

avatar image

Ninjin
4.2k 88 38 152

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question