x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Importing FBX files reorients mirrored objects.

Ive noticed that when I export objects as .fbx files then import them into unreal they were sometimes appearing scrambled and rearranged in the editor. Upon further inspection it seems that when I use the mirror tool in 3ds max and export the resulting file it will reorient the mirrored objects. This happens despite fbx version used and despite 3ds max version used (I've tried multiple times). The only thing that seems to fix it is to attach every object in my scene together before exporting.

Of course this isn't as much of a problem now that Unreal allows .obj models to be imported but it still seems odd to me. Anyone got any ideas here? Or maybe theirs something I'm missing? I haven't really seen anyone having this same problem either. Anyone who can explain this has my gratitude. alt text

Product Version: Not Selected
Tags:
fbx_weirdness.jpg (216.3 kB)
more ▼

asked Jul 16 '14 at 03:59 PM in Bug Reports

avatar image

sneakyferret
21 1 3 3

avatar image Tim Hobson ♦♦ STAFF Jul 18 '14 at 05:36 PM

Hi,

I've setup a simple scene using geometry similar to yours. I have three separate components in mine. The box, the arms that come out. The one on the left is a mirrored copy of the right. I left the mirror modifier there to see if that would cause the issue but did now.

Can you provide an FBX that is doing this and also detailed repro steps?

Which version of the engine are you using? If it's 4.3, are you able to reproduce this in 4.2 or 4.1?

Thank you!

Tim

avatar image XWILKINX Jan 08 '15 at 06:17 AM

Is there a solution for this? Same issue is happening to me in version 4.6.1.

avatar image Tim Hobson ♦♦ STAFF Jan 08 '15 at 02:37 PM

@XWILKINX:

Can you list any repro steps along with this or provide an asset for testing. In my original testing with an OBJ vs FBX I was not able to see this behavior. I also never heard back from the original poster to narrow this down further.

Any steps you have along with program you are using would be helpful for me to investigate further.

Thank you!

Tim

avatar image XWILKINX Jan 08 '15 at 05:58 PM

WIthin 3ds Max, I have an object. I create a clone of this object and flip it on the X axis using the mirror tool.

I export the 3ds Max file as an FBX.

I import the exported FBX to UE4 as a skeletal or static mesh. Looking at the mesh, the cloned object appears as if it was never flipped.

I attached some screenshots in both 3ds Max 2015 and Unreal Engine (4.6.1). You can see how the flipped objects (weapon rail guards) act as if they were never flipped.

alt text

alt text

avatar image Tim Hobson ♦♦ STAFF Jan 08 '15 at 06:37 PM

I am still unable to reproduce this with Max 2013.

When you say "Clone" your mesh, are you doing a copy, instance, or reference to the one it was "cloned" from? I've tried with copy and instance with everything working as intended.

There has to be a step that is being assumed here and not mentioned that is leading to this behavior. :/

Would you mind detailing all your steps from Max to UE4 to get the error. I don't have access to Max 2015 and the guy on our support team that has it on his machine is out this week. So just to narrow down the other steps first would be good to know.

Here are my steps:

  1. Created a cylinder with some extruded faces to easily tell which part is where

  2. tried a copy and a instance of the mesh (separate tests)

  3. Exported both the original and the "clone" in the same FBX

  4. Imported into UE4 (Tested with combined and with combined unchecked)

These are my steps. I didn't get have any issue with this at all.

Here is the FBX and the Max file I used if you'd like to test as well.

link text

Thank you!

Tim

test1.zip (60.4 kB)
avatar image spacehawk May 04 '16 at 07:52 AM

I have the same issue .. using mirror can cause it to flip in a weird way in unreal engine...I am trying some other methords to flip. the strange thing is this only happens sometimes. and sometimes it dosent when exported as fbx

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hola! Tengo el mismo problema. Pero lo pude resolver. El problema está en que se pierde la referencia de coordenadas. Para que esto no suceda debes emparentar el objeto problematico a un padre. Una vez hecho esto no tendrás ese problema. Y funciona incluso con animaciones y esqueletos. Saludos,

more ▼

answered Apr 20 '15 at 07:48 PM

avatar image

karldamianos
6 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi SneakyFerret,

Since I've not heard back from you in a few days I'm going to mark this as resolved for our tracking purposes. If you are still having the issue please feel free to post here with the relevant information requested above.

Thank you!

Tim

more ▼

answered Jul 21 '14 at 04:08 PM

avatar image

Tim Hobson ♦♦ STAFF
48.7k 888 103 880

avatar image spacehawk May 04 '16 at 07:58 AM

I have a feeling that it takes mirror as a absalute -100 scale in all axis this is why the deformation looks like that. while we are trying to do a mirror scale of -100 on x axis.. I havnt found a solution to fix it . even if I manualy scale it it wont work. so I have centred it to the scene and rescaled it in unreal. but the section that I am having the issue with is rather small so wasn't a problem to fix it

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi guys, I just came across the same problem, so this behaviour ist still a thing, but i found a workaround.

Just use the group function of max and export the group itself. I havn't tested if this works with symmetry modifier, but it works fine for the mirrored meshes, instanced or copied.

more ▼

answered Apr 09 '18 at 12:07 PM

avatar image

MrCash87
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question