x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Spotlight's light occluded facing towards camera

I'm working on lighting a level for a game in which players use flash lights to navigate a backyard area at night. I'm using a movable directional light for the sun, and a movable skylight for ambient light.

The issue I'm running into is that whenever a player shines the light (a spotlight) towards the game camera (which is at a static position showing the field), the light seems to get occluded by the grass static mesh, giving off less light. I'm trying to avoid this because I want the player to be able to see the same cone of light from all angles.

Here's an example: Cone A is what I get facing away from the camera actor. The Cone B is facing towards the camera. Note how it is barely visible.

alt text

Here's a view from the other side. These are the same exact lights with same properties; however, I moved the camera around to the back, so now Cone B is on the left. The same problem persists where the light facing the camera loses visual effect.

alt text

So essentially I'm curious as to what actually causes this light "occlusion" to happen. Is there a light/static mesh property I can set to where I get the visual result of the Left cone regardless of direction?

Product Version: UE 4.15
Tags:
cone-1.jpg (246.1 kB)
cone-2.jpg (238.7 kB)
more ▼

asked Aug 30 '17 at 09:12 PM in Using UE4

avatar image

GMaul
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Just disable shadowcasting on your light

more ▼

answered Aug 30 '17 at 09:35 PM

avatar image

Deathrey
7.9k 130 31 293

avatar image GMaul Aug 30 '17 at 09:52 PM

Both lights shown in the screen captures have shadow casting turned off. Sorry, I forgot to mention that detail in the post.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question