x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to prevent a point light from affecting another room?

I'm building a demo that will consist of several rooms from a mansion and it is modular in design. I've gone through the Lighting Troubleshooting Guide and tried several of the fixes including leaked lighting, two sided materials, my UV light map layout and also tried extruding a couple of my meshes into boxes(currently using plane meshes) thinking it would block out the light. With the attenuation radius on my light overlapping into Room A, how do I prevent it from affecting Room B?

alt text

Product Version: UE 4.15
Tags:
more ▼

asked Aug 31 '17 at 04:09 AM in Using UE4

avatar image

Acealmighty13
1 3 5

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Since you mention light maps I presume you are baking the light? You said you have already checked your meshes for leaks so its probably lightmass.

In lightmass you generally need to turn the settings up to get a high quality bake that does not penetrate. In your world settings>Lightmass. Try turning your level scale down slightly, your indirect lighting quality up, and your smoothness down. The level scale has the most impact, as it will directly increase your samples. It will have a MAJOR effect on your bake times as well. Try just increasing quality to 3, smoothness to .8, see how it is. If its still bad try taking the scale to .75. In production bakes I have seen scale set to 0.1. Render time jumps to easily 6+ hours for a tiny level.

more ▼

answered Aug 31 '17 at 10:56 AM

avatar image

DanielOrchard
888 17 21 37

avatar image Acealmighty13 Aug 31 '17 at 01:56 PM

I was using baked lighting, or setting up to do so but I ended up with light spots(similar to a disco ball) everywhere. Tried numerous fixes for it and decided for the demo, to go with stationary for now, and if I have time to find a fix for it, switch to static lighting and tweak the lightmass settings as you suggested.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question