x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[bug] Automatic rebuilding engine each time after change some C++ part of the project

How to prevent rebuilding engine again and again each time after change some C++ part of the project, or when created new EMPTY C++ project.
I am using this guide-stepper but nothing help, this f..g engine automatic recompiles each time.

  1. Be sure to compile successfully entire engine (UE4.sln) in VS2013(15)(17) (without cancelation)

  2. Open (YourProject.sln) desired for compilation C++ project in VSXXXX;

  3. Select "Engine" (in "Solution Explorer") and delete it;

  4. Select "Programs" (in "Solution Explorer") and delete it;

  5. Select your project (in "Solution Explorer") and move it from "Games" to root (in "Solution Explorer")

  6. Select "Games" (in "Solution Explorer") and delete it

  7. File->"Save All"

  8. Exit

  9. Open YourProject.sln again in VSXXXX;

  10. Select "YourProject" (in "Solution Explorer") and with right mouse button select "Build"

UE4 source code is from GitHub in zip file
Bug confirmed in 4.16 and 4.17, with VS2015update3 or VS2017

Product Version: UE 4.17
Tags:
more ▼

asked Aug 31 '17 at 02:15 PM in Bug Reports

avatar image

Angel Tsvetkov
277 27 37 54

avatar image Tim C ♦♦ STAFF Aug 31 '17 at 09:20 PM

Hello Angel,

I followed the steps that you outlined using 4.17.1, and when I built the project in step 10, only the project was built for me. The Engine did not get rebuilt. Would you be able to provide some more information?

  • What Solution Configuration and Solution Platform are you building for? Are they the same in both step 1 and step 10?

  • Would it be possible to get the log for the build in step 10 where you see the Engine being rebuilt?

  • What project template did you use when you created your project?

Tim

avatar image Angel Tsvetkov Sep 01 '17 at 08:03 AM

Tim, thank you for your short respond:
Something automatic replace "Build" with "Rebuild" in Vs2015(17)
1. Both for Engine and Project are the same: Solution Configuration="Development Editor", Solution Platform="Win64". I always choose Build (on UE4 in Engine or MyProject in Games), never Rebuild!!!
2. I attached log for building "temp" Project (C++ Basic Code Template) in VS2015 and log for UE4 engine
3. Project Template: C++ Basic Code

Here is my last step example:

  1. I Build successfully UE4.sln (Build, "Development Editor", Win64)

  2. Then I start "UE4Editor.exe" and create C++ Basic Code Template called "temp"

  3. In VS2015u3 in "Solution Explorer" I remove all except "temp" (like is described in Guide-Stepper above)

  4. Save All

  5. Close VS2015u3

  6. Open again and Build "temp" (Build, "Development Editor", Win64)

  7. =>Instead to compile and build only "temp" for a minute, the entire engine start to building AGAIN AND AGAIN AND AGAIN for hour(s) (including with "temp")

Conclusion: Something is generally broken and automatic replace "Build" with "Rebuild" in VS2015u3(17)
Project "temp" log - project log from temp_Intermediate_Build_Unused
Engine UE4 log - engine log from UnrealEngine_Engine_Saved_Logs

avatar image Tim C ♦♦ STAFF Sep 01 '17 at 08:00 PM

I tried following the new steps that you provided, but still did not see the full Engine rebuild. Could you locate the BuildConfiguration.xml file and insert the following lines in between the Configuration tags:

 <BuildConfiguration>
     <LogLevel>Verbose</LogLevel>
 </BuildConfiguration>

If you run through the build steps again, you will get a much more detailed log that will hopefully show us why a rebuild of the Engine is being performed.

Do you see this also happen if you do not remove the Engine and Programs source code from the solution explorer window?

Tim

avatar image Angel Tsvetkov Sep 02 '17 at 06:54 PM

There is no different if I remove or not.
I repeat again the stepper 1-7 with Verbose
NO difference. Nothing work.
Engine Always REBUILD instead of BUILD, even when select Project only->Buils only temp Project.
Hours lasted. This is tremendous failure guys. Whats the point of the new versions, if older are BETTER and at least WORKING?????(4.17.1 stuck on splash screen and can'r never run. I reported another bug about this but who cares- no one respond 2nd week)
After 4.13 something in UE4 is total broken.
[logs][1] [1]: /storage/temp/211967-cabclogs.zip

cabclogs.zip (1.9 MB)
avatar image Angel Tsvetkov Sep 03 '17 at 01:26 PM

Tim, just for comparison, today I downloaded "UnrealEngine-4.12.zip" and compile via "Build" successfully.
Also compile via "Build" other three C++ projects- all work well. No bug found here.
The same work and with "UnrealEngine-4.12.5-release.zip". So the conclusions is: newer versions of UE4> 4.12.5 have this BUG (confirmed by me on 4.13.2-release, 4.14.3-release, 4.15 and 4.16)
Just my head doesn't understand how only me have this f..g problem? Or nobody use C++ in these versions, or combination of hardware and software somehow automatic replace "Build" with "Rebuild" in VS2015(17)

avatar image Angel Tsvetkov Sep 14 '17 at 12:32 PM

The same BUG (automatic Rebuild instead of Build command) present and in "UnrealEngine-master.zip" master branch 4.18.0-0+UE4

avatar image Angel Tsvetkov Sep 14 '17 at 07:51 PM

Some engineer from Epic messed up Built with Rebuilt in VS. Pease, restore the working version of UE 4.12.5 or below! All month without solution. What the f..k?????

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Finally I resolved this BUG in such way with tested "UnrealEngine-master.zip" master branch 4.18.0-0+UE4 (12.09.2017):

  1. Build "UE4"

  2. Replace the line "bIsEngineInstalled.Value;" with "return true;" in "UnrealBuildTool.cs".

  3. Build "UnrealBuildTool"

  4. Done


UPDATE #1:
After compilation there maybe will occur some harmless error(s), but your project will be build without errors or warnings. If you want perfect and clean compilation you must procomment these four lines in function "static void SaveUBTMakefile(...)" in "UnrealBuildTool.cs" file:

//if (!UBTMakefile.IsValidMakefile())
// {
// throw new BuildException("Can't save a makefile that has invalid contents. See UBTMakefile.IsValidMakefile()");
// }
Then build "UnrealBuildTool" Project again and you are ready, without needed to wait the whole Engine to recompile again and again each time when compile your project!


UPDATE #2:[24.9.2017]
If you will use this method, you can't build light in Editor ("Lightning Build Failed. Swarm Failed to Kick off"):
First, you must restore the original "UnrealBuildTool.cs", then Build "UnrealBuildTool" in VS, then Build "UnrealLightmass" in VS, then Build the light in Editor, then make above changes in "UnrealBuildTool.cs", then Build "UnrealBuildTool" in VS, then you can change and Build your C++ project (without to automatic start Rebuilding of all Engine) and then all cycle again for new light.
SUMMARIZE:

  1. Before to compile your C++ project, you must set my changes in "UnrealBuildTool.cs" file and Build/Rebuild "UnrealBuildTool" project in VS;

  2. Before to build the light in Editor, you must remove my changes in "UnrealBuildTool.cs" file and Build/Rebuild "UnrealBuildTool" project in VS;

CONCLUSION:
I want my name for this BUG- found and resolved this little f..g s..t- more than two f...g weeks spent in researching and testing with different UE versions :):):)

more ▼

answered Sep 16 '17 at 02:17 PM

avatar image

Angel Tsvetkov
277 27 37 54

avatar image EvoPulseGaming Jan 07 '18 at 04:25 AM

Do you still have to do this? I added 2 simple lines to assetdata.h (engine code) and the whole engine is recompiling...

avatar image Marsh Lefler Apr 21 '18 at 02:45 PM

I'm actually having the exact same issue. Every time I attempt to build the engine or personal project it completely rebuilds - even without touching a single file. I am on windows 7 professional. I'm only going to add a few details here to Angel's explanation above in hopes something can be done to fix it other than having to change the code above.

I only started getting this AFTER I made a shipping build using the "RunUAT BuildGraph" command. Everything before doing that worked just fine( took seconds to compile changes ). I had all sorts of issues however with getting RunUAT BuildGraph to run. First my computer only had VS 2012 and VS 2017 and it seems it needed to have VS2015 so I installed that. Here is that bug:

https://forums.unrealengine.com/development-discussion/engine-source-github/113790-installed-build-fails-trying-to-run-pdbcopy-exe

Once I got everything building a shipping version, I went back to build the editor in “development editor” and that’s when it broke. I figured I just needed to do a clean. Which I did and still same result. ( again just building without touching anything does a full rebuild )

Figured I did something stupid when attempting to get the runUAT BuildGraph script running. The thing is I only touched the installedEngineBuild.xml. I can't imagine that has anything to do with building locally. However, I did revert it. Same thing.

In what I thought was surely going to fix it, I blow away my custom unreal engine( from github ) and resynced. Rebuilt. Then did a quick build with no changes and it fully rebuilds. - not fixed.

I decided to remove VS2015 and VS2017 and reinstalled VS2017. Same thing.

I added the verbose to my buildconfiguration.xml as Tim mentioned above. I've attached it. Interestingly it now is saying... 12>UnrealBuildTool: VERBOSE: Couldn't resolve included file "x.h" There are a ton of header files listed.

I’m going to keep looking and hope for a none code change.

avatar image 6r0m Jan 08 '19 at 09:35 PM

did you find solution? I get this problem after using "RunUAT BuildGraph" for Linux packaging, because from Editor it's very slow. now Source always building no matter, that I choose only project

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1.Clear all UE4 process 2.Build UnrealHeaderTool by Development

more ▼

answered Aug 13 '18 at 09:31 AM

avatar image

笙歌那年
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question