x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Setting up visual assist x

I've completely given up on getting intellisense to work correctly, so I'm moving on to visual assist x. I've been having trouble getting intellisense to auto-complete/view basic unreal function (such as GetPawn), and I'm having the same issue with visual assist x, which leads me to believe I don't have something turned on? It loaded correctly, and there's a ton of new highlighting that wasn't there before, so I'm sure its activated. I'm new to game dev, started learning a couple days ago and realizing more and more that auto-complete/function lookup is really important.

Thanks

Product Version: UE 4.17
Tags:
more ▼

asked Aug 31 '17 at 07:55 PM in C++ Programming

avatar image

Fullmetal7777
1 1 2 2

avatar image WTChrisG Sep 01 '17 at 05:53 PM

Hey Fullmetal,

Sorry to hear you are having trouble. Could I get an example of code line which is causing your issue? I tested the following from inside an ACharacter method, for example, and it worked properly.

GetController()->GetPawn()

avatar image Fullmetal7777 Sep 01 '17 at 11:32 PM

So I'm not too knowledgeable, but following the top rated course on udemy at the moment, but heres an example of code from the course. http://prntscr.com/gg0x71. Currently when I mouse over any function, it wont show a preview of the parameters, or any information on it.

avatar image WTChrisG Sep 02 '17 at 04:14 PM

Sometimes that happens because IntelliSense hasn't finished parsing the file you opened. When you can't see the previews, is the following "loading bar" present at the bottom of your Visual Studio window?

https://imgur.com/4lJPIT4

If so, try waiting for it to disappear before attempting to preview.

avatar image Fullmetal7777 Sep 02 '17 at 04:39 PM

Oh I'm well past that at this point lol for instance, I've left visual studios up on my PC all night, came back this morning and still nothing. It never really pops up to be honest, but I have intellisense "Disable IntelliSense" set to False, so its enabled.

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first
more ▼

answered Aug 31 '17 at 08:45 PM

avatar image

VictorBurgos
2.4k 60 27 111

avatar image Fullmetal7777 Sep 01 '17 at 12:49 AM

The last one was the only article I hadn't seen, and it didn't change anything :\ I had to re-enable VAssist, so I'm pretty sure it did something, but no fix. Anything else you can think of?

(comments are locked)
10|2000 characters needed characters left

The following document contains suggestions for improving IntelliSense with UE4:

https://support.wholetomato.com/default.asp?W783

more ▼

answered Sep 15 '17 at 01:42 AM

avatar image

Whole Tomato
11 1 1

(comments are locked)
10|2000 characters needed characters left

Have you tried going to this option and Parse all files when I open this project. restart VAX and then close and reopen all files then give it a sec and it should work.

[1]: /storage/temp/217863-vaxtab.jpg

vaxtab.jpg (42.3 kB)
more ▼

answered Oct 25 '17 at 12:50 PM

avatar image

jvp2001
1 1 3

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question