x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Project crashing when opening any Blueprint

I'm becoming increasingly frustrated with this issue. It's appeared twice now, and it's pretty much impeded progress both times. The issue is that sometimes, if I close a project and come back to it later, upon reloading the project, opening any Blueprint (or any map) will cause the whole Editor to crash and show this error message:

Assertion failed: bCustomPropertyListForPostConstructionInitialized [File:D:\Build\++UE4+Release-4.17+Compile\Sync\Engine\Source\Runtime\Engine\Private\BlueprintGeneratedClass.cpp] [Line: 563]

I have no clue why this is happening. I save every file I'm working on every time to make sure that issues like this don't happen. The first time, I managed to fix the issue by methodically removing files from the Content folder until it stopped crashing, then found that many Blueprint variables had somehow become corrupted. I spent hours adding references back, inserting links between nodes that had somehow disappeared and ticking checkboxes on some boolean nodes that had become unticked. I also did a thorough sweep of the project to make sure there were no circular references and combed through every file to make sure there was nothing that felt off.

I checked online for a definitive solution or prevention method, and nothing that was suggested worked. I tried backing up then deleting the Intermediate, Build and Saved folders and this didn't solve the issue.

It's just happened again. If anyone has a solution to this issue, I'd very much appreciate it because it's a complete roadblock on my progress.

Product Version: UE 4.17
Tags:
more ▼

asked Sep 01 '17 at 04:43 PM in Bug Reports

avatar image

danielilett
11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question