Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Help! Point light only emits in one direction

]Hi there! I have a problem while lighting my level in UE4 4.11.2 (Windows). Whenever I use a point light, it will only light in one direction, and a directional light doesn´t even light at all. For some reason, this only happens when trying to illuminate the landscape, created with the sculptor tool in UE4. Both the point and directional light work fine on assets brought from 3ds max. I´ve tried the lights in stationary, static and movable, and the problem remains the same. Also when I build the lights, they completely dissapear after they are build.

alt text As you can see in the pic, the point light only lights one side, and those 2 lights in the back are the same problem. alt text In this pic, the directional light does nothing in the landscape but as I said before, it lights the assets brought from 3ds max, in this case, the folliage. alt text Also, as you can see in this one, if I put a directional light in the other side of the landscape, it will light it.

The white stripes are rain particles, I left it for the screenshots just in case it may have something to do. Thank you for your time and excuse any grammar mistakes since english is my second language.

Product Version: UE 4.11
more ▼

asked Sep 01 '17 at 10:19 PM in Rendering

avatar image

6 1 3

avatar image hextrap Sep 05 '17 at 06:38 PM

The point light actually looks as if it is using an ies profile, and they are often rotated differently. I doubt that the issue was this, but I thought I'd say it just in case

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Solved it! alt text

So I created a new material for the landscape, doing the exact same thing and exact same textures I did with the previous one, and for some reason, now it is working normally. SoI guess is solved....but not a clue why!

more ▼

answered Sep 03 '17 at 06:15 PM

avatar image

6 1 3

avatar image Nuclear Arbitor Sep 05 '17 at 08:25 PM

Cool. Please mark this as solved then.

avatar image Arty-McLabin Sep 05 '17 at 10:30 PM

mark as solved please.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I just had a similar problem happen in my project on 4.17

Try adding a Lightmass Importance Volume around the area Also try adding Reflection Captures. If that light is static and you're using the metalic property on your material, it needs a Reflection Capture

more ▼

answered Sep 02 '17 at 03:07 AM

avatar image

2.2k 40 17 52

avatar image Nuclear Arbitor Sep 02 '17 at 04:52 AM

given how hard the cutoff is there, i suspect the default lightmass volume is in place and was not expanded with the terrain.

avatar image BenVlodgi Sep 02 '17 at 07:10 AM

Did that solve your issue?

Unreal does create a Lightmass Importance Volume if you don't specify one, but I don't know how well it does at covering everything you want.

avatar image Nuclear Arbitor Sep 02 '17 at 07:12 AM

I did not know that. I assumed the main map had been used and the volume for that one left in place.

avatar image Carlosantonmoya Sep 02 '17 at 09:52 AM

I´ve tried all of those things but the problem remains the same. The level already had a Lightmass Importance Volume and a Precomputed Visibility Voulme (both covering the whole level from every side). The landscape has only a multimaterial with just the base texture, no normals, no metallic, roughness, just the texture.

avatar image Nuclear Arbitor Sep 02 '17 at 10:00 AM

Have you done a full build (not just lighting?) I've found that to have effects in lighting even with fully dynamic setups.

It looks like it's one section of the terrain that's having issues. Is there a terrain seam there or is it one cell of a piece of terrain?

Do you have any volumes in that area that might be causing issues?

Have you made any changes to the level or project lighting settings?

avatar image Carlosantonmoya Sep 02 '17 at 10:09 AM

Yeah, just in case, I always do the full build. About the terrain, I tried putting lights in different areas of the map but same issue (in the first pic you can see two more point lights in the back, with the same issue). About the volumes, I tried switching absoultely all of them on and off and building, but no results. Anyway, I just have the Lightmass Importance Voulme, an Precomputed Visibility Voulme and a Postprocess Volume. I havn´t made any changes on the project lighting settings.

avatar image Nuclear Arbitor Sep 02 '17 at 10:11 AM

I'm running out of ideas. Have you tried a new terrain section?

avatar image Carlosantonmoya Sep 02 '17 at 10:22 AM

Wow, ok this is just getting weirder. I just tried adding a new section and yes, both the point light and the spot light worked fine! But then I builded and only the point light was working, the spot light wasn´t lighting at all (this nex section is covered by the lightmass and precomputed visibility volumes too). Will try changing the whole landscape for a new one and will let you know what happens. (I have to go so won´t be able to post until 10 or 11 hours tho)

avatar image BenVlodgi Sep 02 '17 at 02:45 PM

Did you somehow change the Lightmap Resolution on that section of terrain?

avatar image Carlosantonmoya Sep 03 '17 at 05:07 PM

Sorry for the delay. So I erased the landscape and added a new one, At first, with the texture that came attached to the new landscape, lights would work fine, but then I put the multi material and started painting the landscape. The whole map turned dark and lights no longer afect it, and the problem with the point light appears again. Maybe some problem with multi materials and light? About the Lightmap Resolution, no, I did not.

avatar image Carlosantonmoya Sep 03 '17 at 05:23 PM

So I destroyed everything, all voulmes, the directional light, sky sphere, etc and put them back in the default settings, but the issure remains the same. Tried with absoultely nothing too, just the landscape with the multim material, and same problem, so the problem has to be the multimaterial. ![alt text][1] In this pic you can see how the point light works just fine in this piece of landscape that doesn´t have the multimaterial, while the moment the light reaches the area where the multimaterial starts, it stops lighting in all directions [1]: /storage/temp/212074-screenshot00006.png

screenshot00006.png (793.0 kB)
avatar image BenVlodgi Sep 03 '17 at 05:47 PM

I suggested it before, but did you add reflection captures to the area? Like a BoxReflectionCapture?

It looks like the end of a Reflection Capture area's fall-off at the edge.

avatar image Carlosantonmoya Sep 03 '17 at 05:57 PM

It had no reflection captures, anyway tried adding but the result is the same

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question