x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Visual Studio 2017 Issue

My problem is that I am willing to learn c++ , but cannot edit a singel file with ue4! So, I donwloaded Vs2017 ,had ue 4 before that. The onstallation should be straight forward- select for desktop option and for gaming. Specifically selected also windows SDK 8.1 , not ue installer.(had it) now I think I've set up everything regarding c++ for gaming. I start vs, could make a project ,run it in the console-fine. Now I go to the ue4 launcher. I start a new project. First blueprint-new c++ file-generating-ERROR 32 bit toolchain not found. And the same when I try to generate a new C++ ue project from the library. Epic says it's supported since 4.15 and i've tried it with that version as well. Uninstalled 2017 everything again. Whyyyyyy I tried everything. Don't come with me with VS2015 itried that too. Wasn't able to install c++ toolset with that and so on. I need a simple solution for 2017. Why does it have to be so complicated. A step by step instruction would be perfect. I am very thankful for a solution.

Output: The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Program Files/Epic Games/UE_4.17/Engine/Binaries/DotNET/UnrealBuildTool.exe cpper Development Win64 -project="C:/Users/A/Documents/Unreal Projects/cpper/cpper.uproject" -editorrecompile -progress -NoHotReloadFromIDE Performing full C++ include scan (building a new target) Creating makefile for cpper (no existing makefile) @progress push 5% Parsing headers for cpperEditor Running UnrealHeaderTool "C:\Users\A\Documents\Unreal Projects\cpper\cpper.uproject" "C:\Users\A\Documents\Unreal Projects\cpper\Intermediate\Build\Win64\cpperEditor\Development\cpperEditor.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed Reflection code generated for cpperEditor in 13,2737006 seconds @progress pop ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe

alt text

Product Version: UE 4.17
Tags:
vsisuue.png (598.9 kB)
more ▼

asked Sep 03 '17 at 07:45 PM in Using UE4

avatar image

Aleksandro
207 7 16 16

avatar image Dex82 Sep 04 '17 at 11:26 AM

Mmh,

Just dont start VS before. Start the epic launcher and create a new c++ project. Then it will autostart VS. Be sure you have all tools you need in VS 17 if not it will show you.

avatar image Aleksandro Sep 04 '17 at 06:30 PM

I updated my issue. I tried it like you said. Still error When i press Open VS it says:

Could not edit the code editing IDE. C:/Users/A/Documents/Unreal Projects/cpper/cpper.sln could not be found.

avatar image Aleksandro Oct 06 '17 at 07:30 PM

I don't know why but after a normal Windows update the error dissapeared. It is very strange cause i did't Change anything form last time. it launches VS 2017 and it can run changes i make in c++ tutorial Projects.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Maybe you need VS 2015 to open it. That solved alot of my probs

more ▼

answered Sep 04 '17 at 06:39 PM

avatar image

Dex82
1 3 1 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question