x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

C++ class not appering in content browser after build

Hi.

Just a bit of background info, i'm using Linux and the version of the engine from github. The problem is when i add a c++ class and build the project in my IDE (CodeLite) the class does not appear in the content browser. Any help would be greatly appreciated. (Just a note this problem also happened in 4.16)

Thanks

Product Version: UE 4.17
Tags:
more ▼

asked Sep 04 '17 at 12:24 PM in C++ Programming

avatar image

Rowan_creeper
26 2 4 7

avatar image Rowan_creeper Sep 25 '17 at 09:18 AM

Please Help.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

The class, you want, must be UObject's derived class.

The UCLASS macro must contains BlueprintType and Blueprintable, if you want spawn a blueprint from it.

Like this:

 UCLASS(BlueprintType, Blueprintable)
 class UMyClass : public UObject
 {
     GENERATED_UCLASS_BODY()
 
 public:
 };

Turn on the Show C++ Classes in View Options: alt text

more ▼

answered Sep 06 '17 at 04:00 PM

avatar image

c4g.io
241 1 4 4

avatar image Rowan_creeper Sep 08 '17 at 10:52 AM

show C++ classes is enabled but it is still not showing.

avatar image c4g.io Sep 09 '17 at 02:49 PM

I am not sure your code is right. Can you show your code lines?

avatar image Rowan_creeper Sep 10 '17 at 01:29 PM

At the moment its just the default generated code

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Not sure, so be careful to trust this:

  • Either create the class from the UE editor, or

  • create the class in your C++ IDE, then right click in the filesystem (explorer, Total Commander, ...) your .project and select "Generate Visual Studio Files".

Not 100% sure, so it would be nice if you told us, if it works as I think.

more ▼

answered Sep 08 '17 at 11:12 AM

avatar image

BugSwat
210 9 14 20

avatar image BugSwat Sep 08 '17 at 11:19 AM

If the above is not working, in the UE editor there is a menu item "File/Refresh Visual Studio Project". You could try that one.

avatar image Rowan_creeper Sep 09 '17 at 02:46 PM

I have tried to refresh the c++ project in the UE editor but it didn't help

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question