x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Is there a way to run a dedicated server with Steam without packaging?

Hey guys, I have to get our dedicated server setup with Steam and everything and the only way that I can get it to work with Steam is to package the dedicated server and then insert the steam_appid.txt into the win64 folder. Is there a way to run the dedicated server from the editor using a command like this and still be able to connect to Steam API?

 <UE4Editor.exe> <uproject file path> -server -log

Id kinda rather not have to take a long time to package every time I need to make a change and test and make sure steam integration works on a dedicated server.

Thanks!

Product Version: UE 4.17
Tags:
more ▼

asked Sep 05 '17 at 02:25 AM in Packaging & Deployment

avatar image

CyberblastSoft
253 9 12 76

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Docs explains:

https://docs.unrealengine.com/latest/INT/Programming/Online/Steam/

In DefaultEngine.ini in config directory of your pject paste this and set the id:

 [OnlineSubsystemSteam]
 bEnabled=true
 SteamDevAppId=480

Looking on the code this will write steam_appid.txt in right place. Note that editor running on same base code as packaged game, so behavior should be the same, just if you use UE4Editor.exe your project and enigne directory is game directory.

more ▼

answered Sep 05 '17 at 04:43 AM

avatar image

Shadowriver
37.8k 937 172 1123

avatar image CyberblastSoft Sep 05 '17 at 05:35 AM

That is strange because I ran the command to start it just like I posted above and it seems like it does not generate the file and it still says Failed to Initialize Steam API on the dedicated server unless I package it and run it. And I do have the settings in my DefaultEngine.ini like that with my own app id and bEnable = true under [OnlineSubsystemSteam]

avatar image Shadowriver Sep 06 '17 at 01:39 PM

Ok try setting SteamAppId too in ini, also you can try pasting txt file in to UE4 binery directory.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question