x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Cannot posses child pawn

I'm trying to setup a blueprint hierarchy so that I can then create multi-crewed vehicles. A ship where 1 player can drive and another controls a turret. I make a "hull" Blueprint, with parent class of "Pawn" and another blueprint for a gun turret also using Pawn as its parent class.

On their own, placed into the editor, I can posses them just fine and my input handling is all working perfectly.

Now I want to make the Turrent blueprint a child within the Hull blueprint, I add the ChildActor component, select my Turret blueprint, but now when it comes to possessing it, nothing works.

Instead the camera just switches to a 0,0,0 point in the map with default rotation and nada in terms of behaviour. I'm also not able to access the ChildActor member variables and methods in a standard manner which is a bit annoying really... seems I'm either not understanding the purpose of this ChildActor component or its completely borked.

Can someone please point me in the right direction so that I can have a multi-crewed vehicle as described above?

Product Version: Not Selected
Tags:
more ▼

asked Jul 16 '14 at 09:34 PM in Blueprint Scripting

avatar image

Wobbleyheadedbob
68 6 9 8

avatar image Wobbleyheadedbob Jul 16 '14 at 10:50 PM

Ok, seems as though they've made changes in the latest patch (4.3.0) where the Child Actor no longer shows up in the Scene Outliner while editing... so now I'm even further back... yay.

So even if I were able to get a reference to the now dynamically spawned Child Pawn, I'd only be back where I started. ffs!!!! I switched to UE4 over Unity because of this very reason!!! Are there no tools out there that can properly handle object hierarchies!?!?!

/rant

avatar image RimmyD Jul 17 '14 at 01:50 AM

Have your tried spawning your Turret at runtime and attaching it, then trying to possess? ChildActor component seems a little wonky so i wondered if this approach would avoid any issues it may have.

avatar image Wobbleyheadedbob Jul 17 '14 at 08:31 AM

I haven't tried that but I did try something a little simpler. I dropped both Pawns into the scene in the editor. I then created the attachment in the Level Blueprint between the Turret and the Hull triggered by the BeginPlay event. I was able to posses both Pawns but the turret remained stationary whilst piloting the hull.

I thought maybe I'd configured the Attach node wrong but I tried every available permutation to configure it but still got the same behaviour every time.

I'm getting the feeling my initial attempt didn't work because the child actors only get spawned at runtime. Having set the reference to the child pawn up in the editor may essentially have created a reference to a temporary actor that ceased to exist when the simulation started?

Update: Came across this on the roadmap - https://trello.com/c/L2A8Wie7/279-prefabs Looks like I'm going top have to wait for this to be properly implemented.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Haven't been on here in a while.

Your suggestion worked by the way. Though i wasn't seeing it properly as the Pawn I was spawning was initially set the static hence it not properly attaching.

more ▼

answered May 13 '16 at 01:35 PM

avatar image

Wobbleyheadedbob
68 6 9 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question