x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ACharacter JumpMaxHoldTime quickly prevents jumping on the server

I filed a bug report stating that this didn't work in a predicted environment (gave infinite jumps) and you've now fixed it so thanks for that. Unfortunately the fix has a significant bug of it's own.

After jumping several times with JumpMaxHoldTime set to anything above 0.0 (as in, it's enabled) will quickly prevent the player from being able to jump at all on the server. Meaning the CanJump method is likely returning false on the server and true on the client when the server should also be returning true.

I tested it in a new project using a template to confirm my suspicions aren't on my end and recorded the steps I took for you to reproduce it:

  1. Create a blueprint template for SideScroller

  2. Navigate the content browser to Content/SideScrollerBP/Blueprints and open SideScrollerCharacter

  3. Change JumpMaxHoldTime to 0.12 (or anything over 0)

  4. Next to the Play button is a down arrow, click it and press "Run Dedicated Server"

  5. Press Play

  6. Jump repeatedly as fast as you can. Server will very quickly start snapping you back to the floor.

Occurs for all players on dedicated server. Occurs for anyone other than the host on listen server. Does not occur on single player (player count set to 1 and dedicated server unchecked).

Product Version: UE 4.17
Tags:
more ▼

asked Sep 05 '17 at 08:38 AM in Bug Reports

avatar image

Vaei
576 28 24 50

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi,

I was able to reproduce this and I have gone ahead and submitted a bug report. If you would like to keep an eye on it, you can view it here through the link to the public tracker in which I have provided.

-Thank you

more ▼

answered Sep 18 '17 at 09:32 PM

avatar image

Ridley R ♦♦ STAFF
1.2k 2 4 4

avatar image Vaei Oct 17 '17 at 04:35 AM

Hi Ridley, I have fixed it myself and submitted the PR https://github.com/EpicGames/UnrealEngine/pull/4136

Was a bit strange that it got backlogged so I finally got around to cloning a source build and fixing this (and other things) myself

avatar image Ridley R ♦♦ STAFF Oct 17 '17 at 06:26 PM

Hi,

It looks like the Pull Request has already been submitted and assigned for review.

-Thank you for your submission

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question