x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

ARKit doesn't work with portrait device orientation

Landscape orientation is good but Portrait doesn't work. Looks like camera picture is ok, but placing objects and planes estimates are still in landscape mode. No problems with it in XCode or Unity.

Thank you :)

Product Version: UE 4.17
Tags:
more ▼

asked Sep 05 '17 at 07:37 PM in Bug Reports

avatar image

gamescodedogs
190 4 14 21

avatar image nicksava Oct 07 '17 at 07:23 PM

Any updates or know if this is fixed in 4.18 preview?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I don't know if it's because of the 4.18.3 hotfix, or not - but if you remove all video feed backgrounds cube that you've created (based on Epic/Apple's documentation for implementing ARKit, this is what you were supposed to do) - it actually works for portrait and landscape. So actually - you don't need anything but a player with a camera that does hit tests. No need for fixes for color and stuff, too. Tested on iPhone 8 with iOS 11.2.2 and UE4.18.3

more ▼

answered Jan 18 '18 at 04:14 PM

avatar image

Shaisa
56 3 4

avatar image nicksava Jan 19 '18 at 06:30 PM

Hey Shaisa,

Apologies as I'm following your posts from forum to here - but really struggling since October to get an app released with ARKit and Unreal because of all this (I'm sure you can relate)

Anyway - I've tried this in 4.18.3: Enable Start in AR Mode Delete all cubes/backgrounds Add camera to player (performs hit tests on player screen touch) -This results in a black feed (no camera) but I can see the game objects being placed

I've also tried: Enable Start in AR Mode Delete all cubes/backgrounds Add camera to player (performs hit tests on player screen touch) Add ARKitMaterial as post process material to Player Camera -This results in perfectly working camera feed, but I can't see ANY game actors or objects :(

Any ideas? I really appreciate any thoughts you might have!

Thank you

avatar image Shaisa Jan 20 '18 at 11:32 AM

Have you added this:

 <key>NSCameraUsageDescription</key>\n<string>UE4 needs permission to use the camera in order to use ARKit.</string>\n

to the Additional Plist Data in Project Settings > IOS? More here https://www.unrealengine.com/en-US/blog/getting-started-with-ue4-and-arkit

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question