x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Collision (Scene Depth) not working on a GPU particle.

Hey guys!

I am following the tutorial for particles from the official YouTube channel. I've gotten to the GPU sprite part, and I have problem with the collision. It doesn't collide with my meshes or brushes (I converted the brush, I thought that might have been a problem.)

Here is a screenshot. http://puu.sh/aeFaq/82a7314380.jpg

I am using version 4.3

So, what did I do wrong here?

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Jul 17 '14 at 12:58 AM in Rendering

avatar image

Motanum
620 58 63 306

avatar image Lovecraft_K ♦♦ STAFF Jul 17 '14 at 03:46 PM

Hi Motanum -

What is your response set to, Stop, Bounce or Kill? Also when you converted your brush did you check to make sure the generated mesh has collision. If not add a Box-Simplified Collision and test again.

Thank You

Eric Ketchum

avatar image Motanum Jul 17 '14 at 04:39 PM

Thanks for the answer! I changed back to a brush, even added a chair for testing.

The response is set to bounce. You can see the particles just going through.

http://puu.sh/aftdP/944f5dbc6f.jpg

avatar image Lovecraft_K ♦♦ STAFF Jul 17 '14 at 05:18 PM

Now the collision for GPU particles work on Scene Depth so if you camera is not rendering the floor than no collision will occur. For instance:

alt text

alt text

Your newest image seems to have this problem whereas your old image seems to just be the lack of a collision object. Try to look at your particles from a downward angle and see if they do not bounce. Also try increasing the Const Acceleration I am using something around -750 on Z. Just trying to pull those particles downward to make sure that they are still alive to produce that bounce.

Let me know -

Eric Ketchum

partwork.jpg (86.8 kB)
partbroken.jpg (63.5 kB)
avatar image Motanum Jul 17 '14 at 06:00 PM

Thanks for the quick responses, but still no luck. http://puu.sh/afyJF/847adc34e0.jpg

the original acceleration was -980 on the Z.

Tried to take the picture from the top down, and added an extra brush to the scene. the chair aint colliding either.

avatar image Lovecraft_K ♦♦ STAFF Jul 17 '14 at 06:40 PM

Hi Motanum -

Can you upload your particle system's *.uasset file for us to test or if you can give me a screenshot of your various modules' detail panels so I can make sure I reproduce your exact particle system?

Thank You

Eric Ketchum

avatar image Motanum Jul 17 '14 at 06:47 PM

Sure thing! Here you have, the particle system and the material it uses.

https://www.dropbox.com/s/giju4c4pk69ykj0/Gooey%20Particle%20no%20collision.rar

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Motanum -

Uncheck "Use Local Space" in the Required Module and collision will work fine. This is because the Collision on GPU particles calls from Scene Depth and cannot function in local space.

Thank You

Eric Ketchum

more ▼

answered Jul 17 '14 at 07:12 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 734

avatar image Motanum Jul 17 '14 at 07:15 PM

Thanks man! That worked!

avatar image AzzaMatta2571 Jan 02 '18 at 01:11 AM

I have the same issue but I have unchecked "Use Local Space" and get the same problem

avatar image anonymoussalt Apr 13 '18 at 11:32 PM

same here - did you find a fix?

avatar image AzzaMatta2571 Apr 14 '18 at 01:11 AM

Nope no fix yet

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question