x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Mesh Distance Fields on planes extend past mesh bounds

Edit: Moved to bug reports. While I don't know if this is a known behavior or not, I can't imagine that it is intentional. Also, finally updated to 4.17.1 and this still happens.

Edit 2: This also happens if you apply a Distance Field Replacement Mesh to a plane, where the replacement mesh is from a 3D mesh that does not see this issue. The DF visualization of this mesh on the plane is different (overflows the mesh bounds) than on the closed mesh.

I want to use DF soft shadows in my level, so I'm building it out using small modular pieces, since they seem to get better results (fewer artifacts) than large meshes due to the 128^3 max DF texture limit. Most of the meshes that make up my walls, floors, etc are essentially just single-sided planes with cutouts or details added.

Here's the problem I'm having: the mesh distance fields for 2D planes reliably extend past the actual bounds of the mesh itself, even with DF resolution maxed out. This is not a problem I've seen with 3D meshes. Here's an example using the engine cube and plane:

alt text

Note that the DF representation of the cube is entirely within the mesh bounds whereas the plane's representation extends past the bounding box on all sides.

This creates shadowing artifacts like this where two walls meet at a 90-degree angle:

alt text

You can see the cause of this by visualising DFs at this intersection. Note that they should be meeting at a 90 degree angle without overlapping:

alt text

I've tested this on imported meshes, too, and the same behavior occurs. Importing a plane results in DF overflowing the bounds, extruding it into a 3D mesh and reimporting "fixes" it.

Product Version: UE 4.17
Tags:
plane-df.png (242.6 kB)
wall-normal.png (3.4 MB)
wall-df.png (426.8 kB)
more ▼

asked Sep 07 '17 at 06:11 AM in Bug Reports

avatar image

Meowstopher
76 6 6 8

avatar image Thomas G ♦♦ STAFF Sep 19 '17 at 05:34 PM

Hey,

I was unable to reproduce this issue on our end, I have a couple of questions to help narrow down the issue you are experiencing.

  1. Can you reproduce this issue in a new project?

  2. If So could you provide a detailed list of steps so that I can reproduce this issue on our end?

Thanks!

avatar image Meowstopher Sep 19 '17 at 11:20 PM

Hi Thomas,

I can reproduce this in a new project. Here's what I did to produce the scene below, which mimics the first image in the OP (albeit with the default level in the background):

alt text

  1. Create a new project via the editor launcher (I'm running v4.17.1). For expediency, I chose a blank Blueprint project with default settings (Desktop/Max quality/With Starter Content).

  2. Check Edit -> Project Settings -> Rendering -> Lighting -> Generate Mesh Distance Fields.

  3. Restart the editor.

  4. Once Mesh DFs are all generated, drag a cube mesh and a plane mesh into the level from the Modes -> Place -> Basic menu.

  5. Open the plane mesh in the Static Mesh editor and set LOD Sections (LOD0) -> Build Settings -> Distance Field Resolution Scale to 2.0 (if left at 1, this plane doesn't generate a visible DF at all). You can also set it higher - the issue still occurs.

  6. Show -> Visualize -> Mesh DistanceFields.

Hope this helps. Please let me know if there's any more information you need.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey again,

With the information you provided I have reproduced this issue and logged a report for it here

https://issues.unrealengine.com/issue/UE-50102

You can track the report's status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

Have a good day

more ▼

answered Sep 20 '17 at 07:55 PM

avatar image

Thomas G ♦♦ STAFF
7k 64 4 54

avatar image Meowstopher Sep 21 '17 at 08:38 AM

Thanks, Thomas. To clarify, this also occurs with planes at a DF resolution scale of 1.0.

For some reason, the DF representation of the built-in engine Plane mesh is non-existent at this resolution, but if you import a larger simple plane, it has the same issue even at a resolution scale of 1.0.

alt text

df-plane-dfr1.png (447.2 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question