x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Very High GPU usage in Not Demanding Game

I have made a simple 3D endless falling game that should not require a lot of graphics power and runs well on low end CPUs but in editor and after packaging the game it uses 50% of my GTX 1060 6gb OC gpu, I know how to improve the fps a bit but there is this thing called HZB SetupMips Mips:1 ..9 512x512 that uses the GPU way too much. Usually on the GPU Profiler it shows that it takes around 6-10ms and even once was at 22ms while the rest of the total is usually 8ms. Could somebody please explain why it takes so much processing power and how to disable it? alt text

Product Version: UE 4.17
Tags:
highgpuusage.png (36.7 kB)
more ▼

asked Sep 07 '17 at 11:31 AM in Everything Else

avatar image

Rolandem
21 8 8 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi Rolandem,

you should try the console command r.HZBOcclusion=0, if it fixes the GPU usage you could add these lignes to your DefaultEngine.ini

 [SystemSettings]
 r.HZBOcclusion=0

more ▼

answered Sep 08 '17 at 07:42 AM

avatar image


1.5k 47 32 104

avatar image Rolandem Sep 08 '17 at 06:18 PM

The command does not change anything :/ the setting still kills the GPU, sometimes even 27+ms ..... only way to avoid the low fps is by playing the game at 240p :/

I dont know when it changed but now Mips:1 ..8 256x256 is using all the gpu but the 512x512 is at 0.01ms :/alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It seems to be a known issue of it, and also there is a ticket open for it, but one thing I've noticied is that this problem might not happens on cooked version, can you test it?

more ▼

answered Sep 08 '17 at 07:04 PM

avatar image

Iotti
524 1 4 8

avatar image Rolandem Sep 09 '17 at 12:18 AM

I have tried packaging it to windows 32 and 64 bit with different setting like the setting that optimizes the blueprint code and also have tried packaging a development and shipping version but all the same :/ A interesting thing to note though is that on android the game seems to run well.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have also turned off ambient occulusion and taa (Or it was called txaa maybe) as aparently the setting does some depth calculations for screen space occulusion :/ but the same problem persists. I will need to check out my other projects with ProfileGPU as duplicating and upgrading the ue version on my main project have not fixed the bad fps. epic games really need to fix this, can not release a game that runs below 30fps on gaming pcs that should get 300+ fps.

more ▼

answered Sep 09 '17 at 12:23 AM

avatar image

Rolandem
21 8 8 14

avatar image Rolandem Sep 09 '17 at 05:22 PM

My 4.15 and 4.14 projects have the same problem except for a 4.10 project which basically has the same problem but the SetupMips is replaced by Ambien Occlusion alt text

410-project.png (39.1 kB)
avatar image Rolandem Sep 09 '17 at 05:35 PM

After finding a forum where people suggested to use these commands: r.SSR 0 r.HZBOcclusion 0 r.SSR.quality 0 r.AmbientOcclusionLevels 0 The ProfileGPU shows that the map's ligh source 0 is using up the time that the HZB setupmips was using :/ alt text

wow it even went up to 38ms ... woow please if someone knows how to fix this or what it is at least please tell me i am desperate, though weirdly the gpu gets used about 35-40% instead of 55-60% but still performance should be way better

plzhelp.png (35.3 kB)
avatar image Rolandem Sep 09 '17 at 07:24 PM

After playing around with the Sun Lightsource and Skylight settings (in the end leaving them as they were) now for some reason this was happening alt text

Then after setting the commands all to 1 (r.SSR 0 r.HZBOcclusion 0 r.SSR.quality 0 r.AmbientOcclusionLevels 0) for some reason the particle system is eating up the GPU although i have like 3-4 really basic particles in the scene

alt text

After setting the commands to 0 again (they are called every time when level starts so I dont know why they did not work after playing around with the lights) the BasePass -> Static EBasePassDrawListType=0 is taking up 20ms again

screenshot-2.png (63.0 kB)
screenshot-wtf.png (33.1 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question