x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't see new Native components in BPs when added in C++

Hey guys,

So I altered one of my C++ classes to include a native spring component and an attached native camera, but these won't show up in the Components tab. I had to make a whole new Blueprint, which means whenever I want to change my native components, I need to copy across all of my functions, event handling, defaults tab settings, etc. This has a huge impact on my workflow.

Is this a bug, and if so, is it already known / being worked on?

Thanks!

EDIT: This is also the case with BPs that inherit from a BP that itself inherits from the native class in which these changes are occurring. If I have a base class in C++ whose components I change, every single BP that inherits in some way from this (BP->Code or BP->BP->Code) have to be completely rebuilt to see the new components. That's a problem.

Product Version: Not Selected
Tags:
more ▼

asked Jul 17 '14 at 05:15 AM in Bug Reports

avatar image

HateDread
453 41 47 72

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you.

more ▼

answered Oct 07 '14 at 06:20 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Try deleting your Saved and DerivedDataCache folder to force the BPs to be rebuilt.

more ▼

answered Jul 17 '14 at 08:37 PM

avatar image

cgrebeld
497 25 16 33

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question