Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

First destructible mesh in level disappearing without fracturing

I have a level containing around 500 destructible cubes. Whenever I load it, first couple of cubes don't fracture when damage is applied to them, just disappear without creating any chunks. After destroying ~10 of them everything works correctly (chunks are created).

Chunk count for each cube is 40. The usual Apex max chunk count shouldn't matter in this situation, because there are no active chunks in the scene.

Product Version: UE 4.16
more ▼

asked Sep 08 '17 at 09:31 AM in Blueprint Scripting

avatar image

1 2 4

avatar image sg_badyl Sep 10 '17 at 09:31 AM

Nevermind, it was related to p.APEXMaxDestructibleDynamicChunkCount after all, but it only worked after I changed it in the general engine config file. Looking for a way to change it for single project only now.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Okay, got it working. Even after changing the engine's ConsoleVariables.ini file the packaged game would not keep the settings.

What I did is add PhysX/APEX modules to dependencies (in Build.cs):

 PublicDependencyModuleNames.AddRange(new string[] { "Core", "CoreUObject", "Engine", "InputCore", "PhysX", "APEX" });

Then include the PhysXIncludes and PhysicsPublic file:

 #include "PhysXIncludes.h"
 #include "PhysicsPublic.h"

And finally override the max chunk count property of ApexModuleDestructible:

 GApexModuleDestructible->setMaxChunkCount((physx::PxU32) MyDestructiblesCount);

This works, but I am not sure if it's not a very 'hacky' way of approaching this. I will mark this as an answer and the question can probably be closed.

more ▼

answered Sep 11 '17 at 04:58 AM

avatar image

1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question