x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Animation Retargeting Problem...

Hello! I've made a character model and I'm trying to retarget the UE4 ThirdPerson animations to it.

I've only done it two times, but the first time went fine (although that was in version 4.10). I now updated UE4 to 4.17 and made a new model, and set the bones exactly like the UE4 character(except for the twists and ik_hand things, since I have no idea how to do those, but I could skip them the first time).

I've set up the humanoid rig (although I noticed the save pose option is gone now).

But after I retarget the animations I just get a very weird animation of the hands or something that I can't tell what part of the model it is, depending on which animations I retarget...

Only weird things I've noticed is when I set the humanoid rig on either character a message pops up saying I need to save the skeleton, which I did, but it keeps popping up no matter what...

On my first try in 4.10 everything went well, but now I just get this weird picture of 2 hands... I followed this tutorial, not sure if anything changed in 4.17 to make this not work anymore :/ https://www.youtube.com/watch?v=6QGh06nF6To

I'm new to modelling aswell so it could also be some problems with the model/bones...

Does anyone know what the problem could be ?

alt text

alt text

alt text

Product Version: UE 4.17
Tags:
thumbnail.png (3.0 kB)
animation.jpg (332.4 kB)
bones.jpg (345.2 kB)
more ▼

asked Sep 09 '17 at 10:15 PM in Using UE4

avatar image

Ason
1 1 2

avatar image Ason Sep 10 '17 at 03:39 PM

I've tried to make new bones in blender but still get the same problem, I also tried with my first character that worked fine in v4.10 but that one also doesn't work now... Would really appreciate some help :'(

avatar image Ason Sep 10 '17 at 04:21 PM

I also tried with the same character in 4.10, here's how it looks, it seems like all bones are connected togheter or something... alt text

410.jpg (361.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Turns out the way I made the bones doesn't work in 4.17 anymore, I used rigify in blender and got a decent result.

more ▼

answered Oct 06 '17 at 07:27 AM

avatar image

Ason
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question