Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Why does my render target have no alpha channel

I am trying to render an existing texture (with an alpha channel) to a render target via a material.

The material has a texture sample with the relevant texture. I have tried setting the Material Domain to both "Surface" and "Deffered Decal" and in both I've tried setting the blend mode to translucent.

Then I have an actor with a SceneCapture2D and a Billboard. The billboard has the material described above as its (only) sprite element. The ScreenCapture2D is positioned 32uu away so it can see all (but only) the billboard. This has its Texture Target set to a TextureRenderTarget2D.

If I view this Texture Render Target with the channels RGB enabled, it looks like a slightly washed out version of the texture (if you know how to fix this, that would be appreciated) but if I look at the alpha channel, it appears totally black.

How can I make it so the SceneCapture2D writes to the alpha channel? I'm sure it is just a case of setting some options in the material and the Screen Capturer, but I have no idea what.

Product Version: Not Selected
more ▼

asked Jul 17 '14 at 10:27 AM in Rendering

avatar image

646 44 58 90

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi thk123 -

The Scene Capture 2D actor does / cannot record an alpha channel. The alpha would be a transparency and the capture actor saves a straight no transparency image to the texture.

As far as the blurriness / washed out appearance, I would adjust some of the Scene Capture Actor's post process settings to help eliminate that. I also find that increasing the Render Texture's resolution as allowed by you project also helps clear up images. If you can give me a screenshot, I can help you work through the exact settings.

If you can give me a brief description of what exactly you are tyring to achieve explicitly I can also help you work through a different possible solution.

Thank You and let me know -

Eric Ketchum

more ▼

answered Jul 17 '14 at 04:22 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image rustwd Feb 19 '15 at 12:35 PM

I found your answer. I have the similar task. You could add me on facebook or skype?

avatar image Valentin Slobozanin Apr 23 '15 at 03:54 PM

Did you find a way to record alpha channel of a scenecapture2D to the texture render target? I would be very interested in

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question