x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Failed to open descriptor file" on 2nd Local PC

Hi, I've encountered this "Failed to open description file" error that others have also been seeing, but I believe mine is caused by a slightly different reason. Here were the steps:

  1. Package existing project folder into a .zip file

  2. Transfer .zip file to 2nd PC, and extract

  3. Generate new VS solution file & open

  4. Try to launch UE4 Editor from VS

  5. Get the error: Failed to open description file [PATH NAME to .uproject file]

Here's the hint though: the PATH NAME is that of the 1st PC. The 2nd PC doesn't even have a D drive, but the path shown in the error is of the original project's path name, which is on the D drive of the 1st PC.

Am I not transporting the project properly? Are there additional steps that I am missing? Any help would be appreciated!

Product Version: UE 4.17
Tags:
more ▼

asked Sep 11 '17 at 05:04 PM in Packaging & Deployment

avatar image

Orakga
35 5 11 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

My apologies. Noob mistake.

I had deleted the "Intermediate" folder but not the "Saved" folder before rebuilding on the 2nd PC.

more ▼

answered Sep 11 '17 at 10:12 PM

avatar image

Orakga
35 5 11 14

avatar image FlawsomeInteractive Sep 12 '17 at 12:53 AM

I'm having the same issue now working with the ARKit Sample on a Mac. Deleting the "Saved" and "Intermediate" folder didn't seem to affect anything. Any ideas?

avatar image Orakga Sep 27 '17 at 08:33 PM

Hi Flawsome, I'm not sure if this will help, but when transferring projects, the only things you need to transfer are supposedly:

  1. THREE folders: Config, Content and Source

  2. The .uproject file

After that, you can rebuild it on any computer, on any platform. At least that's been my experience so far. So, perhaps try just copying those "necessary folders/files" only and try again?

avatar image pavle_lgl Jan 12 '18 at 12:47 PM

Hey! I downloaded the ARKit example project and had the same issue. Deleting those folders didn't help, but moving the project to /Users/Shared/Epic Games/UE_4.17 did the trick as it was clearly trying to access the default absolute path. Not sure how to change this path tho, so for now, the example project will be in my Editor folder :)

avatar image MOSBozhidar Sep 05 '18 at 02:02 PM

Is this where your engine install directory is?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question