x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Text array does not contain what the editor show me

This is the text array within the UMG Blueprint Editor:

alt text

This is the array when accessed trough blueprint(bottom to top):

alt text

This is not the first version of 4.17 this have happened in.

Product Version: UE 4.17
Tags:
more ▼

asked Sep 11 '17 at 05:54 PM in Bug Reports

avatar image

fanzypantz
357 30 41 62

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Try loop over that array on your Construction Event. Chances are you change it during runtime or Conditionaly Skip some entrys before printing them. I also noticed the order is in place just with a few skips and that one Entry does not match up "View Distance" and "View Distance Quality".

Double check that. I did not notice any out of order Entries in Arrays or skips in 4.17

more ▼

answered Sep 11 '17 at 06:56 PM

avatar image

Nachtmahr
6.8k 142 24 165

avatar image fanzypantz Sep 11 '17 at 07:12 PM

This is the only place where I touch the array in the blueprint(inherits from default class): alt text It's inside an UMG widget blueprint. I looped over and tested to get the text on certain indexes, both in the "pre construct" and on "construct". Now after restarting the editor the array thinks it's just one index long and I look in the log which tells me that there is nothing at these indexes. It thinks the array is one item long.

PIE: Error: Blueprint Runtime Error: Attempted to access index 3 from array OptionNames of length 1! from function: 'ExecuteUbergraph_BP_OptionsMenu' from node: Print String in graph: EventGraph in object: BP_OptionsMenu with description: Attempted to access index 3 from array OptionNames of length 1!

Video showing the setup

avatar image Nachtmahr Sep 11 '17 at 08:10 PM

if you do a refference search make sure to uncheck "Find in current BP Only" your option Names can be modified outside of this Widget BP. If you create a copy of that variable and read it from there the error should not occour at all.

avatar image fanzypantz Sep 11 '17 at 08:17 PM

I did now, nothing else is referencing it. It's literally the last thing I've done on the project. If something else is accessing this text array, then someone is hacking my computer and have added code into the project without me knowing... Which I highly doubt.

That getter for the "Options Names" is the only single place in the project it's being used other than in the default variable assignment.

Just to be on the safe side, I tried to loop over it trough the character blueprint. It still only give me back a single item..

avatar image Nachtmahr Sep 11 '17 at 08:25 PM

Thats indeed very strange but if it can´t be reproduced (tried on my Engine) its unlikely that me or the Staff can find a fix for it since the cause is unknown. In your case I would try to make a new FName array and try it with that (give it another name just to be sure). For now I assume your default Object got corrupted somehow and its a one off bug.

If it still happens I would suggest sharing your project with Staff only to look over it. (got to wait for a reply from them in that case)

avatar image fanzypantz Sep 12 '17 at 10:18 AM

Well I changed it to a string array, which now worked. But the issue still persists with the text array.

avatar image alonezhby Dec 11 '18 at 04:49 AM

I have same issue,
seems, TextArray can only ForEachLoop 5 times at runtime, but editor mode works. I changed to string array works.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question