x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

GPU Particle Collision with Translucent Mesh

Greetings!

I've been trying to get some GPU particles to collide with a translucent mesh without much success.

I am using "Distance Field" collision on my emitter, but that is not enough apparently. Is it impossible, after all, to have GPU particles collide with translucent meshes?

ps: even when I make the mesh opaque (setting the material opacity to 1), there is no change regarding the particles collision with it.

----EDIT----

I'm not sure this is useful, but when using CPU particles, they collide just fine, but I cannot afford the limit they impose (i.e. I need a LOT of particles on screen).

Also, the GPU particles collide just fine with "regular" materials (on the same mesh), so the problem, as far as I know, really lies within the translucency itself.

----EDIT 2----

Here is exactly what I am trying to do:

I have a cylinder that, at first, is opaque. Its material, however, is translucent, and using "Camera Depth Fade", I make part of it invisible in order to reveal its interior.

Inside of said cylinder, there's a particle emitter. Those particles should be kept inside the mesh, but they just go right through it.

What I tried (to no avail):

  • Removing "Camera Depth Fade"

  • Setting opacity to 1

  • Making the material two-sided

  • Adding actual geometry inside the cylinder

  • Messing around with the particles scale

  • Messing around with the collision parameters in the particle (though not a lot, I admit)

ps: I was playing around with the material and emitter while writing this edit, and noticed that the particles are not colliding even when the material blend mode is set to "Opaque", so now I am truly confused

Product Version: UE 4.17
Tags:
more ▼

asked Sep 11 '17 at 06:50 PM in Rendering

avatar image

blkhouse_vlucki
190 5 8 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

you may have already found this.

more ▼

answered Sep 13 '17 at 09:06 AM

avatar image

Nuclear Arbitor
313 4 8 10

avatar image blkhouse_vlucki Sep 13 '17 at 12:58 PM

Indeed, that post is where I saw about using "Distance Field" collision. Alas, it did not work either :(

On a side note, I just added some more information regarding my specific situation which may prove useful (in hindsight, that should've been in the original post from the start...)

avatar image Nuclear Arbitor Sep 14 '17 at 01:12 AM

i've just started using gpu particles myself so my knowledge is limited but could you use a collision volume to contain them?

avatar image blkhouse_vlucki Sep 20 '17 at 03:12 PM

It doesn't seem to be respecting any collision whatsoever

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question