Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android builds won't run on API 19 or below. Always Crashes! 4.17.1

Since Unreal Engine 4.16 that any of my games can't run under devices with API 19 or below. The same story in 4.17.

I was expecting in this new engine version to get best android performance, among other things (since my focus is mobile/android development), instead, I had to unsupport all android devices from API 19 and below since every time I package my projects to this devices it always crashes no matter what I do. Every Project I Build for API 21 and up works with no problems!

Steps I'm taking:

1 - Made an APK to support API 15 minimum and target 19 to use ETC1 textures. (NDK 19 and SDK = matchndk)

2 - Made an APK to support API 21 minimum and target 24 to use ETC2 textures and ES2 and ES3.1 and Vulkan (NDK 21 and SDK "latest")

Problem - The APK based on 15/19 does not work and crashes on it's respective devices. Only the APK 21/24 is working correctly with no problems at all!

This happens with all my projects and even with the template projects from UE4.

Screenshots and Logcat:

alt text

link text

Product Version: UE 4.17
log.txt (11.5 kB)
more ▼

asked Sep 11 '17 at 08:20 PM in Packaging & Deployment

avatar image

21 6 10 12

avatar image mightyenigma Sep 12 '17 at 03:06 PM

My android launches crash with no splash screen in this exact situation too. It seems to have something to do with the following monitor log:

java.lang.UnsatisfiedLinkError: Cannot load library: link_image[1891]: 164 could not load needed library 'libOVRPlugin.so' for 'libUE4.so' (find_library[1201]: 164 'libOVRPlugin.so' failed to load previously)

However, I removed all the Oculus VR plugins so I don't know how to get this to stop being a required library. There's nothing left to remove!

avatar image A.SISODIYA Sep 17 '17 at 09:55 AM

This was the only reason why I again switched back to 4.15, This bug r whatever this is costed me a 2 month of a headache. This seems to be a problem with both 4.16 and 4.17 version of engines. I have tried to run my app on both versions 4.16 and 4.17 but my problem have met only a horrible death. My program shows a UE4 splash screen and after few seconds it crashes. They should also add an option of priority Answer Feed or something similar in answerhub. Because after searching on google I have found out that many people seem to be having the same problem.But we have no proper solution for this :(

avatar image PlatinumBlade Sep 17 '17 at 10:09 AM

Yea, I'm on the same boat as you, I'm working on big a project by myself I can't properly test my game on older devices because of this. If only Epic could help with this but I don't think they even know what is going on. I found until now that UE 4.17 is very buggy in some areas :/. Yesterday I was shipping my game to my daily device and suddenly there was 200k shaders to compile .-. that was insane xD

avatar image A.SISODIYA Oct 27 '17 at 04:09 PM

SO have you tried 4.18 , Have they solved the problem?

avatar image A.SISODIYA Oct 01 '17 at 01:20 PM

Is someone going to help us regarding this issue??

avatar image mightyenigma Oct 07 '17 at 01:41 AM

I hope so. I may have to settle for never building an Android game with Unreal otherwise. I've tried quite a few random combinations of settings in Project settings for Android and Android SDK, and installed SDK level 16 to try to make it work with my Samsung Galaxy S2 (Jelly Bean). I'm not installing Visual Studio 2017 over the top of 2013 to see if that will make it work, since someone told me that adding an empty C++ project to my Unreal 4.17.2 project will make it stop crashing on Android app launch, but doing this causes a lot of compile errors and says I need VS 2015. I don't know, maybe I need all three of 2013, 2015, and 2017?

avatar image PlatinumBlade Oct 07 '17 at 12:44 PM

If your project is Blueprints only, your C++ errors maybe are from the "Nativized Assets". I dont have problems with that and do have VS2017 only installed. But I dont think this is the main cause to our true problem here :/

avatar image mightyenigma Oct 27 '17 at 04:12 PM

OK I will look into my VS installs too, and try including a C++ asset to fix it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Guys, I've been trying 4.18 and so far, Api 15/19 is working perfectly as intended. So I'm closing this thread for now. You should really try the new engine version. Have a great day everyone ;)

PS: If you build for API 15/19 it will throw an error with OVRPlugin. Simply disable the OculusVR plugin and the game will package with no problems. At least this happened with me.

more ▼

answered Oct 28 '17 at 09:54 AM

avatar image

21 6 10 12

avatar image mightyenigma Nov 01 '17 at 01:51 PM

Thanks PlatinumBlade, I'll try 4.18.

However, I should mention for others' benefit that in 4.17, disabling OculusVR plugin did NOT solve the problem in my case (I even disabled all plugins with "virtual", "reality", "oculus", or "VR" in the name (actually I disabled every plugin but 3, which were definitely not VR-related).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question