x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't stop projectiles from interacting with player

I have the player firing projectiles from a gun, and I can't stop them from interacting with the player who shot them. I know that ordinarily you would use the "ignore actor when moving" node, but it doesn't seem to be working the way that it should. By using that node, I can stop the projectile from actually colliding with the player, but even as it passes harmlessly through, it's still applying force to the player and launching them. In fact, I don't know why the projectile is applying force at all; there's nothing explicitly set up to have that effect, and I even made sure to disable "apply impulse on damage" for both the projectile and the player.

Product Version: UE 4.17
Tags:
more ▼

asked Sep 12 '17 at 01:52 PM in Blueprint Scripting

avatar image

Grimwolf
157 14 16 26

avatar image chackaloso Nov 04 '17 at 11:40 AM

Did you ever figure this out I am having invisible collision upon full auto firing projectiles...

avatar image Grimwolf Nov 04 '17 at 09:13 PM

No, in the end I just went with line traces instead of projectiles.

avatar image chackaloso Nov 04 '17 at 11:42 PM

Okay, I have both line traces and projectiles for VFX purposes currently. I managed to fix the collision issue I was having. It was basically the ragdoll mesh capsule of the AI after being killed continuing its AI path move to character with out the Body mesh. Like a ghost capsule following me around blocking me from moving lol. So I just put a delete capsule on the variable "isRagdolled" and it worked.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I think I've found the solution. In the settings of the projectile's collision component, I set the collision to query only. This stopped it from automatically interacting with physics objects. In my particular case, I don't need it to do that, so it works fine. If I did need that effect, I could probably just apply an impulse on hit. This is interesting, because not only did it stop the player from getting knocked around as I expected, but it also stopped the collision event from firing when passing through the player. I guess the "ignore actor when moving" node only works correctly if the collision is set to query only.

more ▼

answered Nov 09 '17 at 06:14 PM

avatar image

Grimwolf
157 14 16 26

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question