x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot build lighting

Hello,

I'm using 4.16.3 version and I have a problem with bulding lightning. I have over 4000 unbuilt objects on my scene, and every time when I try to build lighting, I get errors:

Map check finds some errors! Wordl_Settings1 Maps neeed lightining rebuilt!

That's all and I don;t know what should I do. Can you give me some advise?

Product Version: UE 4.16
Tags:
more ▼

asked Sep 12 '17 at 04:13 PM in Using UE4

avatar image

KamPie
1 2 2

avatar image KamPie Sep 15 '17 at 06:42 PM

My swarm log: https://imgur.com/a/MEB97

Tried to delete SwarmCache - still don't work.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

i get the same error when i try and do a full map build with unbuilt lighting. a full build first checks the entire map and finds unbuilt objects. it then generates the error. then, because of process order, it builds the lighting and everything should be fine. if you do a lightmaps only build you shouldn't get that error. i wouldn't worry about it though.

more ▼

answered Sep 12 '17 at 11:14 PM

avatar image

Nuclear Arbitor
313 4 8 10

avatar image KamPie Sep 12 '17 at 11:20 PM

The problem is I get that error even I build only lightning and I don't know how to solve it.

avatar image Nuclear Arbitor Sep 12 '17 at 11:59 PM

hmm. i found this, this, and this. are any of them similar to your issue?

avatar image KamPie Sep 13 '17 at 02:57 PM

https://imgur.com/a/GTWh6

That's how it looks. I tried to duplicate project but it didn't work at all.

Maybe the problem is I don't have any material or textures on my objects?

avatar image Nuclear Arbitor Sep 14 '17 at 01:15 AM

unless you removed the default material on them then they should have something. you could try making a basic material and see if it fixes the issue. it's also possible it has something to do with the wardrobe warning.

avatar image KamPie Sep 15 '17 at 06:12 PM

I created material and applied it for all of the objects on my scene. I deleted wardrobe too, but still I got that error.

I found that thread: https://answers.unrealengine.com/questions/201327/lightning-build-failed-swarm-failed-to-kick-off.html

I tried to delete point lights on my scene - didn't work. Tried to apply material on all elemnts on objects - didn't work.

My swarm agent is starting when I building lightning. Tried to find UE4.sln on my drive but Windows can find it.

I don't know what I have to do. Should I install other version of engine and try then?

avatar image Nuclear Arbitor Sep 16 '17 at 06:54 AM

i would start by making a new level, putting a few basic things in it, and trying to build that. keep going until something breaks. if it doesn't work from the beginning then try a new project.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

My swarm log:

 20:33:28: [Interface:TryOpenConnection] Local connection established
 20:33:28: [Job] Accepted Job 1C674E64-4A0A9F80-2B8B6093-E99C5705
 20:33:29: [Job] Launched Job UnrealLightmass_2017-08-03_16-34-29_1064896-64bit.exe
 20:33:29: [Job]     PID is 6084
 20:33:29: [Job]     GUID is "1C674E64-4A0A9F80-2B8B6093-E99C5705"
 20:33:29: LogLightmass:Display: Lightmass Win64 started on: USER-PC. Command-line: 1C674E644A0A9F802B8B6093E99C5705
 20:33:29: Failed to determine engine directory: Defaulting to ../../../Engine/
 20:33:29: Lightmass Win64 started on: USER-PC. Command-line: 1C674E644A0A9F802B8B6093E99C5705
 20:33:29: LogLightmass:Display: Processing scene GUID: 1C674E644A0A9F802B8B6093E99C5705 with 3 threads
 20:33:29: Processing scene GUID: 1C674E644A0A9F802B8B6093E99C5705 with 3 threads
 20:33:29: Building static lighting...
 20:33:29: [OpenConnection] Registering TCP channel ...
 20:33:29: [OpenConnection] Connecting to agent ...
 20:33:29: [TryOpenConnection] Testing the Agent
 20:33:29: [TryOpenConnection] Opening Connection to Agent
 20:33:29: [TryOpenConnection] Local Process ID is 6084
 20:33:29: [Job] Found a parent connection for PID 6084
 20:33:29: [Job]     7D8E0816 -> 66DF080C
 20:33:29: [Interface:TryOpenConnection] Local connection established
 20:33:36: Measured CPU frequency: 3.00 GHz
 20:33:36: FStaticLightingSystem started using GKDOPMaxTrisPerLeaf: 4
 20:33:36: Number of texture mappings: 377
 20:33:36: Number of fluid mappings:   0
 20:33:36: Number of landscape mappings:   0
 20:33:36: Number of BSP mappings:     0
 20:33:36: Number of static mesh instance mappings: 377
 20:33:44: Scene surface area calculated at 49.407 million units (75.800% of the estimated 65.181 million units)
 20:33:44: Importance volume surface area calculated at 49.407 million units (0.000% of the estimated 0.000 million units)
 20:33:44: Windows GetLastError: Operacja ukoLogWindows:Warning: CreateProc failed (2) ../../../Engine/Binaries/Win64/CrashReportClient.exe "C:/Users/USER/AppData/Local/UnrealEngine/4.16/Saved/Swarm/Engine/Programs/UnrealLightmass/Saved/Crashes/_0000" -AppName=UE4-UnrealLightmass -CrashGUID=_0000 -DebugSymbols=..\..\..\Engine\Intermediate\Symbols
 20:33:44: [Job] Job has failed! Job executable didn't exit cleanly. Exit code: -1066598274
 20:33:44: [CloseConnection] Closing connection 7D8E0816 using handle 7D8E0816
 20:33:44: [CloseConnection] Connection confirmed for disconnection 7D8E0816
 20:33:44: [CloseConnection] Closing orphaned Job (1C674E64-4A0A9F80-2B8B6093-E99C5705)
 20:33:44: [CloseConnection] Orphaning local connection (7D8E0816 is the parent of 66DF080C)
 20:33:44: [CloseConnection] Connection disconnected 7D8E0816
 20:33:44: [GetMessage] Safely returning to 7D8E0816 with no message
 20:33:44: [MaintainConnections] Detected dropped local connection, cleaning up (66DF080C)
 20:33:44: [MaintainConnections] Local connection has closed (7D8E0816)
 20:33:44: [CloseConnection] Closing connection 66DF080C using handle 66DF080C
 20:33:44: [CloseConnection] Connection confirmed for disconnection 66DF080C
 20:33:44: [CloseConnection] Connection disconnected 66DF080C
 20:33:44: [MaintainConnections] Removed connection 7D8E0816
 20:33:44: [GetMessage] Safely returning to 66DF080C with no message
 20:33:45: [MaintainConnections] Local connection has closed (66DF080C)
 20:33:45: [MaintainConnections] Removed connection 66DF080C
 20:33:45: [MaintainConnections] All connections have closed
 
more ▼

answered Sep 18 '17 at 01:11 PM

avatar image

KamPie
1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm going to throw this out there, because it works. You just need to have a PC and a Mac, or a Mac running Windows via Bootcamp (I suppose an emulator might work, I keep ten feet or more away from them myself).

All you do is, copy the project to the other system from where the lighting won't build. Boot up the project on the alternate system, run the lighting build, and voila', it works - you hope. Copy said project back to the system you're creating on, and your lighting is not only built, but will be buildable again on the system it broke on before you did the OS switcher-roo.

I don't question why this works, I just know it's saved me countless hours and leagues of frustration I used to face when the lighting breaks. Which it always does at some point it seems. Usually, near the end when lighting is most complex and the game is almost done. This actually just happened again last night. Worked the switcher-roo = Hi, Murphy. Bye, Murphy.

more ▼

answered Sep 16 '17 at 07:07 AM

avatar image

Ripix
31 1 5 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question