x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Import Uniform Scale Bug

I noticed this problem starting in 4.16, but it seems like it's still an issue in 4.17.

When you're importing a lot of fbx meshes and set the "import uniform scale" to anything other than 1.0, some of the geometry gets imported at the new scale, while others remain at 1.0. Which results in something like this:

alt text

Product Version: UE 4.17
Tags:
bug.png (560.1 kB)
more ▼

asked Sep 12 '17 at 07:01 PM in Bug Reports

avatar image

DFILL450
23 7 12 15

avatar image Ridley R ♦♦ STAFF Sep 19 '17 at 06:59 PM

Hi,

I have taken a look and gone through some repro steps provided, and I believe the results are similar to what you are seeing. I would like to make sure that these are the same issues though. If you could provide some more screenshots/information I can be sure of this. The steps that I took are as follows: Created 3 different meshes in Maya. The sizes were set to centimeters in Maya which is what UE4 uses (64cm, 24cm, and 4cm). I then exported them all out of Maya at a scale of 1.0 as FBX files. Then imported them into 4.17 at the same time. I did this a few times, each time changing the Import Uniform Scale number. The result each time was 3 different meshes on top of each other that were each a different size.

Does this sound like the result that you are getting?

-Thank you

avatar image DFILL450 Sep 20 '17 at 06:44 PM

1) I create a box in 3ds Max, with the units being 1 unit = 1 foot.

2) I copy this box 50 times (to simulate importing a lot of meshes at once)

alt text

3) I drag all of these meshes into the content browser to import. I choose an "Import Uniform Scale" setting of 30.48 to convert the scale to cm (having exported it in feet). I hit import all.

alt text

4) Some of the meshes get imported at the new appropriate scale of 30.48. While others stay at a scale of 1 despite saying that they are 30.48 in the static mesh window.

alt text

alt text

So the bug is basically that after a certain number of meshes get imported, it stops imported at the "import uniform scale" that you set in the import settings and defaults back to 1.0.

capture1.png (68.1 kB)
capture2.png (168.1 kB)
capture4.png (1.8 MB)
capture3.png (1.8 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

This bug is still present in 4.18.3

more ▼

answered Feb 06 '18 at 07:53 PM

avatar image

PatrickWard
6 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi,

I was able to recreate this issue and have logged it as a bug. If you would like to keep an eye on the bug you can track it using this link. If you have anymore questions regarding this thread let me know.

-Thank you

more ▼

answered Sep 21 '17 at 06:07 PM

avatar image

Ridley R ♦♦ STAFF
1.2k 2 4 4

avatar image Haoris Jan 15 '18 at 07:49 PM

The problem is worst than what is in bugtracker description: Once imported, you can set differents values in "import scale uniform" of those imported mesh assets, hit save then clic on reimport and this value will be ignored.

avatar image George Allan CS Mar 11 '19 at 01:35 PM

The import scale issue is happening in 4.20.3 with MegaScans assets (though it doesn't seem to happen with meshes we've created). The "Convert Scene Unit" suggestion below doesn't make any difference either. The only way to affect the static mesh scale post import is to generate blueprints and nest them. This problem doesn't happen in 4.22p2.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

By checking "convert scene unit" can avoid the issue.

more ▼

answered Apr 04 '18 at 08:12 PM

avatar image

ricco_igle
6 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question