x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe. Can't get pas this error! Any help is appreciated!

I am unable to create a new project, or even open an older existing project. Attempted re-installation of MSVS 17 and UE4 4.17, but still can't get past this. Upon opening a "New Project with NO starter content, Base C++ code".

The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Program Files/Epic Games/UE_4.17/Engine/Binaries/DotNET/UnrealBuildTool.exe Section_01 Development Win64 -project="C:/Users/jesse_000/Desktop/Projects/Unreal Project_New/Section_01/Section_01.uproject" -editorrecompile -progress -NoHotReloadFromIDE Creating makefile for Section_01 (no existing makefile) Performing full C++ include scan (no include cache file) @progress push 5% Parsing headers for Section_01Editor Running UnrealHeaderTool "C:\Users\jesse_000\Desktop\Projects\Unreal Project_New\Section_01\Section_01.uproject" "C:\Users\jesse_000\Desktop\Projects\Unreal Project_New\Section_01\Intermediate\Build\Win64\Section_01Editor\Development\Section_01Editor.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed Reflection code generated for Section_01Editor in 12.1024909 seconds @progress pop ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe

Product Version: UE 4.17
Tags:
more ▼

asked Sep 14 '17 at 03:19 PM in C++ Programming

avatar image

Jessepx
11 1 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

This link had the answer for me! https://answers.unrealengine.com/questions/668653/visual-studio-compiler-wrong-path-how-to-change.html#

More specifically, this user's response:

Found the answer - thanks to UE being open source! I've looked at the github code and found where it was taking the path from; it was the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\VisualStudio\SxS\VC7 which inside of it was an entry named "14.0" with the non-existing path. I deleted it, created a new one with "15.0" with the correct path ( "D:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC" for me ), restarted the editor - and it now works. p.s. The above registry key path is just the third path UE will look for; the correct order is: 1. HKEY_CURRENT_USER\SOFTWARE\Microsoft\VisualStudio\SxS\VC7 2. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\SxS\VC7 3. HKEY_CURRENT_USER\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\SxS\VC7 4. HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\SxS\VC7

more ▼

answered Sep 15 '17 at 12:45 AM

avatar image

Jessepx
11 1 4 5

avatar image Aerosz Oct 30 '17 at 12:05 AM

Worked for me, thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had a lot of pain doing this too so I do understand your frustration.

1.Make sure you installed the C++ module with VS. By default this module is not installed. If you did not install C++ or if you are unsure, open the new project dialogue. On the left side it ask you what type of project you want to create, under the online dropdown you will see C++ if it is not installed. When you create the project it will download and install the module for you as well as Windows 8.1 SDK if you don't have that yet.
2.Next you have to restart your computer.
3.Then install UnrealVS as stated in the documentation.

After this I did not reinstall Unreal and it began working. If you do not restart your computer VS will give you problems.

more ▼

answered Sep 14 '17 at 05:15 PM

avatar image

BluHornet
18 1 1 4

avatar image Jessepx Sep 14 '17 at 08:39 PM

I am totally still having issues. I tried doing your steps and the steps of some other posts I found. Such as the resolutions here: https://answers.unrealengine.com/questions/545787/error-no-32-bit-compiler-toolchain-found-in-cprogr.html

But to no avail.

I have, deleted all old MSVS versions, installed a fresh version of VS 2017. However, I must note I wasn't able to find the programs in "Features and Programs" to officially uninstall, so I deleted the root folders in their entirety.

I'm curious if there is a way to change UE4's direction to point at VS 2017? Instead of 2015? I don't even know if that would solve my problem. I'm just trying to get the darned thing to work. Super frustrating I can't even create a new project. It appears I have all the proper modules installed with 2017, so I'm just so confused. I'm to the point I almost want to just re-image my PC. Any other help would be very grateful!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Having Same issues. Just need a way for the UE4 to point and talk with VS17...Help Please! Thank You

more ▼

answered Sep 14 '17 at 08:52 PM

avatar image

SundayRide
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question