x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

collide GPU particles off screen

Is there a way to force GPU particles to collide with something that isn't currently being rendered?

Basically when it is raining i want my character to be able to walk under cover (into a cave) and not have the rain appear in the cave but they should be able to look out from that cover and see the rain outside.

The problem is I'm using GPU particles for the rain and unless I'm looking straight up at the ceiling the particles pass straight thought and render as normal. I understand why this happens i was just wondering if there was a work around.

Would swapping to CPU particles fix this issue? Would rather not as i will have to drastically reduce the number of rain drops but if its the only option.....

Appreciate any help.

Product Version: UE 4.16
Tags:
more ▼

asked Sep 14 '17 at 04:02 PM in Blueprint Scripting

avatar image

Eightshot
143 8 17 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

SOLVED IT!!! You CAN make GPU particles collide off screen, you just have to use "Distance field" instead of Scene depth in the collision > Collision Mode (bottom of the first panel) and have to activate distance field in the project settings. I'm told it is expensive but worth it for my project.

so if anyone else is having this same issue just look up "Distance fields" on youtube.

more ▼

answered Sep 15 '17 at 04:07 PM

avatar image

Eightshot
143 8 17 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

By default the collision from GPU particles is based on screen depth, this 1 of the reason why GPU are faster that CPU, and because of that you cannot make it collide outside the screen, But here is an idea, you can use both, use your GPU particles to fill your scene, and then program some behavior for your CPU particles only under demand, because in any case is rain effect, probably is not hard mix both visually speaking!

Hope this helps!

more ▼

answered Sep 14 '17 at 04:35 PM

avatar image

ZkarmaKun
381 9 12 18

avatar image Eightshot Sep 14 '17 at 06:30 PM

I suspected as much tbh,

Your suggestion, do you mean have 2 particle systems and (for example) when under cover deactivate the GPU particle system and activate the CPU system? Not entirely sure how i would implement this without having a permanent line trace active from my character checking for a roof.

Did you have a system in mind?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question