x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Low FPS on clean blank packaged project in full-screen

Hi,

I'm getting a maximum of 160 FPS on a brand new blank project in UE4. I have two Nvidia GTX 780 in SLI and as a comparison, Overwatch runs at 300 FPS without a problem. I'm using the latest Nvidia drivers. I've originally started my game in 4.15, so went back and checked and it seems to be about 160 FPS there, too.

I've created blank projects in both versions of the engine: without a sky box, lights, meshes... empty, nada, just empty, cold black space... Packaged the game to Win64, disabled smooth frame rate, set min and max framerate to "open".

When I launch the same project as a Standalone Game, I get about 540 FPS in windowed mode at 720p and around 280 FPS at 1080p. Once I switch to full-screen however, it's back to that same 160 FPS.

Am I messing something up big time or might there be a bug running games in full-screen? Overwatch 300 FPS @ full-screen, UE4 empty project 160 FPS... I hope it's just an issue on my end!

Cheers, Dave

Product Version: UE 4.17
Tags:
more ▼

asked Sep 16 '17 at 07:47 AM in Packaging & Deployment

avatar image

GlassBeaver
108 5 14 14

(comments are locked)
10|2000 characters needed characters left

The question has been closed Nov 02 '18 at 11:21 PM by GlassBeaver for the following reason:

The question is answered, right answer was accepted


3 answers: sort voted first

I've found the solution. Turns out you have to create a post-process volume in your level and disable a bunch of things that are enabled by default.

After all that is done, I get about 750 FPS with FXAA anti-aliasing, running a standalone game in full-screen @ 1440p (2560x1440) w/ 2 x GeForce GTX 780 cards in SLI (Zotac AMP! Edition for those who care) and 810 FPS without any form of anti-aliasing. Additionally, by also disabling the tonemapper, I can get to 870 FPS.

Have a look at this: https://answers.unrealengine.com/questions/147462/how-do-i-disable-all-post-processes-entirely.html

Don't forget to disable Mobile HDR and restart the editor!

Disabling the tonemapper: the only way I know right know is to execute the following console command: ShowFlag.Tonemapper 0

Finally, make sure to run your game in standalone mode or cook it, and keep the UE4 editor window minimized.

Below is a screenshot of all the changes I have made to the post-process volume. This is in version 4.18.1, so there are slight updates as to the original answer linked above. Also note that you have to disable anti-aliasing in project settings, and not in the post-process volume.

I am very glad that I've found the aforementioned answer on the forums, as it is essential for me to be able to disable any and every sort of visual effect there is. When you're developing a real game, you have to know what graphical features are costing you resources, be it on the GPU or CPU. To find your game's "graphical sweet spot", experimentation and testing are required, and those can only be carried out by isolating feature sets and enabling them one by one.

Anyway, I hope this helps anyone wishing to reign their FPS in.

Cheers, Dave

alt text

more ▼

answered Nov 25 '17 at 05:05 AM

avatar image

GlassBeaver
108 5 14 14

avatar image GlassBeaver Nov 29 '17 at 02:48 PM

Minor update: I've tried these settings on a project that I'd originally started in 4.15, created an empty map, set up a post process volume and as a result have achieved 1300 FPS (with 0.8ms per frame)

(comments are locked)
10|2000 characters needed characters left

Did you find the solution? Im having the same problem and I couldn't find any thing online

more ▼

answered Nov 06 '17 at 02:08 PM

avatar image

zaid-irq
3 2 2

avatar image GlassBeaver Nov 22 '17 at 03:46 PM

Not really, no. It might be down to some rendering settings that need to be turned off in order to increase the FPS. Not sure what they'd be though.

(comments are locked)
10|2000 characters needed characters left
more ▼

answered Nov 25 '17 at 07:41 AM

avatar image

TextusGames
26 1 3 6

(comments are locked)
10|2000 characters needed characters left

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question