x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Closed] Motion blur ghosting when rendering submeshes with unique transforms.

Hello!

I have my own SceneProxy class (for my own component) which is derived from FPrimitiveSceneProxy. In my DrawDynamicElements I construct FMeshBatch and construct multiple FMeshBatchElement objects for it (these correspond to my submeshes). For each submesh I have a unique transform. Here's how it is rendered:

 DrawDynamicElements(FPrimitiveDrawInterface* PDI, const FSceneView* View) {

 FMeshBatch Mesh; ..... set vb, vertex factory and other stuff...
 FMeshBatchElement& BatchElement = Mesh.Elements[0]; .... set ib, counts here..

 // set transform for this submesh
 FMatrix TransformMatrix = MyTransform * GetLocalToWorld();

 BatchElement.PrimitiveUniformBuffer = CreatePrimitiveUniformBufferImmediate(TransformMatrix, GetBounds(), GetLocalBounds(), false);
 
 PDI->DrawMesh(Mesh);
 }


Objects are correctly placed in the scene, but I experience a really weird ghosting effect when I move them in the editor using gizmos (either translate or rotate). If I disable motion blur in editor ghosting goes away. Has anyone encountered this problem or maybe can suggest a solution / work around?

Thanks.

Product Version: Not Selected
Tags:
more ▼

asked Jul 17 '14 at 09:03 PM in C++ Programming

avatar image

ttvd
333 20 25 35

avatar image ttvd Jul 21 '14 at 08:07 PM

Would be nice to know how to solve this issue. For the moment I solved this by baking transforms into vertex positions for each submesh..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Nov 10 '15 at 04:26 PM by ttvd for the following reason:

Problem is not reproducible or outdated


1 answer: sort voted first

The editor motionblur is not always working like it should be. We want to not have any camera motionblur but we want to have object motionblur. When using Matinee we also change this behavior to be more game like. TemporalAA also shares the motionvectors with motionblur which complicates things further. Objects that gets moved in the editor normally get partly recreated but we try to maintain some state (importan for motionblur as the former frame state decides over the amount of motionblur). Your case might be different or conntected to this issue. To see clearer what issues you have: toggle antialiasing and/or motionblur and try in standalone game and in editor.

more ▼

answered Jul 22 '14 at 05:08 PM

avatar image ttvd Jul 22 '14 at 07:13 PM

It shows up in either standalone or editor. It goes away with motionblur turned off. We solved this problem by baking transformation into vertices on load. Also, thanks for your explanation.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question