x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot install .ipa file from compiled source project to device on iOS 11; Minimum required version error

I have a project that was created in Unreal 4.17 on my PC. Using remote build, I packaged that project into an .ipa file for deployment to an iOS device, and no errors were encountered during packaging. In my iOS settings, the Minimum iOS Version is set to "11 Beta" (the most recent option available; this project is packaged with the ARKit plugin, so iOS v11 is required). However, when attempting to install the .ipa to the device, I received an error message indicating that the device did not meet the required iOS version and that I needed to update to the newest version (the iPad in question has iOS version 11.0, the most recent available). I tried moving the project over to my remote client Mac and installing there, but received the same error, as well as when I tried installing it through XCode.

However, I think I may have found the root cause of the problem in the debug logs of XCode. When attempting to install, I found an error message that read "The system version is lower than the minimum OS version specified for bundle at /private......bunchastuff...Payload/MyProject.app. Have 11.0; need IOS_11". This leads me to believe that there is a problem with how Unreal is labeling the iOS version number in the packaging process, resulting in an engine bug.

I also tried opening the .ipa in a text editor. There are three references to "IOS_11" in the file, including two with labels indicating a Minimum iOS Version, but changing any or all of these in any combination to "11.0" and re-saving resulted in iTunes or XCode refusing to even attempt to install the file; thus, I assume that there's some kind of encoding going on that prevents me from changing the file in this way. Even if I used a binary editor, the number of characters is different.

Does anyone have any additional suggestions? My development has basically halted, as I cannot test my build on the target device.

Product Version: UE 4.17
Tags:
more ▼

asked Sep 22 '17 at 07:29 PM in Bug Reports

avatar image

Matt_GrooveJones
118 10 16 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Just to confirm, this issue does appear to have been fixed in 4.18; not sure about 4.17.2, though.

more ▼

answered Sep 25 '17 at 09:25 PM

avatar image

Matt_GrooveJones
118 10 16 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question