x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Nonsene warning on destructible with active physics

I am working on a skeet shooting simulation in VR.

The skeet is a destructible within its own blueprint and physics is on to simulate the pull phase. When the skeet it is hit by a projectile it is destroyed. Collisions are set to Destructible (therefore Query and Physics) and Generate Hit Events is on.

Everything works fine, except that I keep getting the following warning in the Log file (PIE) and I am not able to get rid of it:

PIE: Warning: Invalid Simulate Options: Body (skeet_DM_BP_C_55.Destructible skeet_DM) is set to simulate physics but Collision Enabled is incompatible

Looking at the source code (PrimitiveComponent.cpp - row 1559), this warning should be issued only if physics is enabled BUT collisions are set to No Collisions or Collision Enabled is set to Query only.

None of this applies to my destructible (double-checked also with Print String on Begin Play), however the warning is issued anyway. Looks like a bug to me.

Cheers, Marco.

Product Version: UE 4.17
Tags:
more ▼

asked Sep 24 '17 at 08:02 PM in Bug Reports

avatar image

vr_marco
2.2k 10 6 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ok never mind. The issue was solved by quitting the project, removing the Intermediate and Saved folder, then reopening the project.

more ▼

answered Sep 24 '17 at 08:34 PM

avatar image

vr_marco
2.2k 10 6 12

avatar image ZLogic Nov 26 '18 at 03:47 PM

Don't do this. Didn't work and scrambled my textures; couldn't just restore the removed files.

avatar image vr_marco Nov 27 '18 at 08:30 PM

There is nothing in the Intermediate and Saved folders that cannot be regenerated automatically by the engine when needed, so if there is a problem with your textures, it is not because of this.

avatar image ZLogic Nov 27 '18 at 11:15 PM

Sorry if I seemed abrasive. I've read that before but there must be some exception in my case. All I know is that I removed those two folders, opened the project, and the textures were all grey monotone. Closing the project and restoring the files didn't fix it. I had to restore the project from source control. This isn't the first time it's done that when I've done this.

avatar image ZLogic Nov 27 '18 at 11:17 PM

I resolved my problem when I realized I was disabling objects' collision during runtime without turning the physics off.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question