x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How do I disable lightmap mipping/streaming?

I have a large outdoor level with a lot of static meshes and the shadows degrade noticeably at 50 meters and disappear at 100 meters. Is there a way to disable or reduce the aggressiveness of the lightmap mipping or streaming?

Product Version: Not Selected
Tags:
more ▼

asked Jul 17 '14 at 11:40 PM in Rendering

avatar image

JonathanLambert
56 4 7 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey JonathanLambert -

You can go into the *.ini files under the TextureStreaming section and make adjusts for lightmaps and shadowmaps. More information can be found here:

https://docs.unrealengine.com/latest/INT/Engine/Content/Types/Textures/Streaming/index.html

Thank You

Eric Ketchum

more ▼

answered Jul 18 '14 at 04:01 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image hyperjams Nov 17 '14 at 07:29 PM

Hey Eric,

I've tried to turn this off in the baseEngine.ini file but the lightmaps still mip. Do you have any additional tips on this?

thanks

avatar image Lovecraft_K ♦♦ STAFF Nov 17 '14 at 09:27 PM

Hey hyperjams -

After building lighhting for the first time, you can go into the World Settings and under Lightmass >> Advanced Rollout and open each lightmap texture individual and set the mip settings individually. You may also want to try to uncheck the compress lightmaps setting. This will increase the size of your project by at least 4x, but may be closer to the look you are after.

Thank You

Eric Ketchum

avatar image hyperjams Nov 21 '14 at 01:44 PM

Hi Eric,

Is there a way to find out what lightmap is associated with which actors? We've tried changing the mip settings on all of them but it doesn't make any difference. It's time consuming to change them all. We could iterate faster on this if we could focus on one lightmap and one actor.

thanks

avatar image Lovecraft_K ♦♦ STAFF Nov 24 '14 at 09:45 PM

Hey hyperjams -

There is not a way to tell which Lightmap contains which actor as it will change based on each light build. Depending on the types of light you have in the level, you can adjust the Cascading Shadows to help with the shadow fade distance from Dynamic to Static with Stationary lights. It could also be that the Lightmap resolution is too low for your meshes you can increase them and allow you light maps to get bigger which will allow for more pixels for a smoother fade gradient.

If you are consistently not getting the results you are looking for and performance is not a concern, the only thing left for me to recommend is to switch to Dynamic Lighting (set all to Movable).

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question