x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Geometry Cache Vs Skeletal, different playback speeds

Hi everyone

I'm trying to design a cinematic using a character imported as a geometry cache. Since that animation doesn't play back when I scrub through the sequencer, I also imported it as a skeletal mesh.

When playing back the two animations on top of each other in PIE the alembic sequence plays at a slightly different rate than it's skeletal counterpart. I double checked the imported frames and the playback settings but I can't get it to work.

Any ideas would be greatly appreciated.

Best Sebastian

Product Version: UE 4.18 Preview
Tags:
more ▼

asked Sep 25 '17 at 10:04 AM in Bug Reports

avatar image

StoriesAG
8 5 7 11

avatar image Ridley R ♦♦ STAFF Sep 25 '17 at 07:34 PM

Hi,

I have just a few questions for you so I can try and pinpoint what the issue is. Can you send me some screenshots or some more information on the steps that you are taking to get these results(steps you are using to import and export)? Also, are you utilizing any plugins or settings in UE4 that are set as experimental? Are the assets rigged etc.? Are you using Max or Maya? And do you get these results in engine version 4.17 as well? Any extra information that you provide will be helpful.

-Thank you

avatar image StoriesAG Sep 26 '17 at 07:45 AM

Hi Ridley

Thank you for such a quick response.

I'm using maya to export my animation. I've tried using UE 4.17 and Maya 2017 and 2018. The character is rigged and I'm selecting the geometry and exporting it to alembic. I'll attach screengrabs from my export settings in Maya as well as my import settings in UE4, my sequencer setup and the alembic playback settings in UE4.

One thing I noticed and I find odd, is that the frames at import have a different number than at export. However since both the GeoCache version and the skeletal version import the same frames I don't think that's a contributing factor.

Please find the screengrabs here: https://transfer.stories.ch/_l4icBKQZMYUE0R

Best Sebastian

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I found a very recently done video on Alembic importing into UE4, but it is mostly 3ds Max and Blender so I don't know if it will be helpful, but I thought I'd link it anyway. If you go to your Playback Speed in the details panel, are the Geometry Cache and Skeletal versions set to the same speed? If you skip ahead to about 12 minutes into the video they talk about changing this. It does not look like there is anything wrong with your import/export settings. However, Alembic is an experimental plugin and is not recommended to be used in a production environment unless you can maintain it. I would recommend trying to utilize the FBX pipeline and see if that works. You also mention above that you are selecting the geometry in Maya, I would double check that your bone hierarchy is also selected. Let me know if any of this helps or solves the issue.

-Thank you

more ▼

answered Sep 26 '17 at 04:33 PM

avatar image

Ridley R ♦♦ STAFF
1.2k 2 4 4

avatar image StoriesAG Sep 27 '17 at 09:19 AM

Hi Ridley

Thank you for the link, I had missed that video and it was really informative. I tried the test again with the joints also exported but since it's a geometry flipbook, they don't even get listed at import :(

The video did list several quality of life improvements coming down the line that I think will address my problem so I guess for now I'll just wait.

Thank you for looking into this.

avatar image Ridley R ♦♦ STAFF Sep 27 '17 at 04:22 PM

Hi,

I'm glad that was helpful. If all fails you should be able to default back to using FBX format. Since this is just the preview for 4.18, I would recommend also checking back in with the issue after it officially releases, or any updates come out. If you have any more questions regarding this thread feel free to reopen it, and I'll get back to you.

-Thank you

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question