x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Unfortunately, [appname] has stopped" on Android 4.1.2 due to libOVRPlugin.so

The problem: When I build an app to Android, then try to launch the app on the android device, it fails to reach the splash screen, goes blank for a few seconds, then pops up with an alert box saying "Unfortunately, MobileTestApp has stopped" (MobileTestApp is my app's name in this scenario).

To reproduce this problem, you'll need:

Windows 8.1 64-bit (I have 8 GB Ram and an Nvidia GeForce GTX 650 Ti Boost running on an Intel i7 processor (Sandy Bridge I think?) Unreal 4.17.2 (Epic Launcher version) Android SDK / Codeworks / whatever it's called. Samsung Galaxy S2 smartphone model SGH-T989 with Android version 4.1.2 installed (mine says Baseband version 989UVMC6, Kernel version 3.0.31-1003885 se.infra@SEP-131 #1 and a bunch of other stuff that the question entry form deleted. I'll try and get that back to you)

Steps to reproduce: Create Blank blueprint project: Scalable mobile no starter content, named MobileTestApp. Save the map it starts on as TestMap. Maps and Modes, and set all the map options to TestMap. In Project Settings > Platforms - Android > APKPackaging, click the button that configures the platform files to be writable (changes the red banner that says it's not set up, to a green one that says it is). Also set Minimum SDK Version to 9, and Maximum SDK Version to 16.

Just in case, check that these match: Under Platforms - Android SDK I have (in order): C:/NVPACK/android-sdk-windows C:/NVPACK/android-ndk-r12b C:/NVPACK/apache-ant-1.8.2 C:/NVPACK/jdk1.8.0_77 matchndk android-16

Plug in the phone to the computer. In Project Launcher, choose Android ETC 1 variant. click Launch.

App builds and installs to the device, and launches it. Wait approx. 5 seconds on blank screen (no splash). App quits with error "Unfortunately, MobileTestApp has stopped."

See my attached logs. It keeps saying it can't find libOVRPlugin.so, which is weird, because in the other logs, it says it copied that to the APK. so I figured, that looks like an Oculus thing from the source path, so how about I disable all the VR-related plugins, restart Unreal, and try a full package rebuild? Makes absolutely no difference. Even when I have turned off everything having to do with Oculus or VR that I can find, it still thinks it needs it for some reason, and it can't find it.

Some people told me to remove references from the .uproject file. This also does not make a difference. I have come to the conclusion that I'm probably (hopefully) not doing anything wrong, but Unreal just really likes including references to Oculus, whether I am using VR or not. I just need a way to get rid of those, and maybe then my app will work? I created no Content for this project. I packaged and deployed it just as it was when it was created, other than changes to the Project Settings, and saving the starting map as TestMap.

Is it possible that my smartphone is supposed to come with something installed on it for Oculus VR in order to be able to run any kind of Unreal 4 app? I am just trying to make a UMG-only app with no VR involved. I have also tried removing almost all the plugins from Unreal.

I thought maybe my smartphone was using an outdated OS, so I went to check for updates, but it pops a message saying "No firmware".

Question on Packaging forum yielded nothing.Similar Bug report by another user has not yet been resolved.

Is the smartphone I am using simply too old to run anything from Unreal?

link text

link text

Product Version: UE 4.17
Tags:
more ▼

asked Sep 26 '17 at 12:43 AM in Bug Reports

avatar image

mightyenigma
3.8k 18 24 21

avatar image mightyenigma Oct 07 '17 at 01:24 AM

I'm going to try installing Visual Studio 2017 Community since I get a lot of compile errors when I added an empty C++ class to my project like many people said to do in order to make it work. I currently have Visual Studio 2013.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Strange: I came back in after adding an unrelated plugin, and found that one VR plugin was ticked, on that I had unticked before and septuple-checked that it and all other VR-related plugins were disabled. I unticked it, and now I can finally get to the frozen "Your Splash Screen Here" message on the android device. That's progress! Now I just have to figure out how to get past that.

more ▼

answered Nov 29 '17 at 07:19 AM

avatar image

mightyenigma
3.8k 18 24 21

avatar image DcCharge Oct 31 '18 at 08:56 PM

I had a similar problem with libOVRPlugin.so plugin crashing in Android 4.3 on an ASUS Tablet (ME302C). UN-ticking Unreal Editor -> Edit -> Plugins -> Virtual Reality -> OculusVR fixed the problem for me. I left SteamVR still ticked but it did not cause a problem.

I was just trying out the C++ version of the Rolling Demo. The only changes I made were to Project -> Supported Platforms which I changed to just Windows and Android. Project -> Target Hardware was set to Mobile/Tablet and Scalable 3D or 2D.

I should note that I ran the very same project on an Android 8.0.0. phone with no problems. This was an ASUS Zenfone3 Zoom.

This happened to me in Unreal Engine Version: 4.20.3-4369336+++UE4+Release-4.20 .

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question