x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Admob Not Showing Test Ads (Blueprint Project)

I'm currently working on an android game and I have followed the Admob documentation for using advertising for android games, I am currently using a Interstitial Test ad ID but I keep getting the warning message "LogAdvertising:Warning: GetAdvertisingProvider called with a module name of None."

Play Services alt text

Advert Blueprint alt text

Product Version: UE 4.15
Tags:
more ▼

asked Sep 27 '17 at 12:49 PM in Using UE4

avatar image

Robbie Marram
18 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Usually, when you use interstitial Ad, you should load it, but you shouldn't show it imediatily, you really should wait for it to load and try to call it later. If the Interstitial Ad wasn't loaded in the moment you try to show it, it'll just ignore it.

I believe there is a function called "IsInterstitialAdAvaliable"(or something like that) that you can use to check if you can show it or not.

more ▼

answered Sep 27 '17 at 01:03 PM

avatar image

Iotti
524 1 4 8

avatar image Robbie Marram Sep 27 '17 at 01:08 PM

I tried your solution but even after a delay of 10 seconds between load and show ad it still returns the bool as false.

avatar image Iotti Sep 27 '17 at 01:53 PM

In that case, you may use the "IsInterstitialAdAvaliable" return to a branch, if true, show, if false, call delay of 2 seconds and go back to "IsInterstitialAdAvaliable".

And just remember that show interstitial Ad will only work on mobile device, PIE should never show it.

avatar image Robbie Marram Sep 27 '17 at 02:24 PM

I tried on event "Begin Construct" (UMG) to "LoadInterstitialAd" and use a 2 seconds "Delay" before Branching using the "IsInterstitialAdAvaliable" which if true executes "ShowInterstitial", but a print string shows that it returns as false, this was tested by packaging the project and deploying it on my andorid device (Sony Xperia Z1)

avatar image Iotti Sep 27 '17 at 04:51 PM

There is a function called "IsInterstititalAdRequested" to check if it could complete a request and start to load it. Try to call it a few seconds after the load request and check if it is true.

Also, check if your app is requesting network usage permissions.

avatar image Robbie Marram Sep 29 '17 at 12:45 PM

From testing the "IsInterstititalAdRequested" returns true but the "IsInterstitialAdAvaliable" which is now attached to a tick (to check if it ever returns true) is always false.

These are the permissions I have: alt text

PS: Not sure if this is a bug but if there is a delay (I had 5 seconds) after "Load Interstitial Ad" the "IsInterstititalAdRequested" would return false.

permissions.png (42.7 kB)
avatar image Robbie Marram Sep 30 '17 at 09:46 AM

Your original suggestion about using a delay was correct, after a some changes and testing I have managed to get it working. Thank you :)

avatar image Sm00lae Oct 15 '17 at 08:20 PM

Hi, Could You tell me what did You change, how did Your final blueprint for Interstitial Ads look like? I'm facing the same problem of ads not showing :(

alt text

All the best, Samuli

capture420.png (157.2 kB)
avatar image Iotti Jan 25 '18 at 06:38 PM

The return value from Is Interstitial Ad Avaliable is not linked to the branch condition, try to pin it and test it again.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question