x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.16-4.17 Bug] Squencer animation playrate inconsistencies

Hello, there are a number of playrate problems when using animations inside of Sequencer that makes looping animations with a different Rate Scale nearly impossible to use.

1. Skeletal Mesh with Use Custom Mode: Animations always play at the rate of 1, despite the actual animation asset having a Rate Scale of 0.5.

-This should be playing at half the speed-

This is fine as however the Play Rate can just be adjusted right there in sequencer.

2. Skeletal Mesh with Use Animation Blueprint: When using the animation blueprint and a Slot to feed in the sequencer animation, the above starts to fall apart. When using the slot, the animation will indeed play at the 0.5 that's set in the animations Rate Scale, however, sequencer will not adjust the loop size, and so the animation plays at half the speed, but then just loops back halfway, as sequencer thinks it's using a Play Rate of 1.

-Animation playing at proper 0.5 Rate Scale, but sequencer still looping as if it was at 1-

This is where the problem lies, as lowering the Play Rate in sequencer adjusts both, so the animation still gets cut off.

3. Scaling the animation track You can slick and drag the left edge of the animation bar to the right to scale/shorten it. However this does not speedup the animation rate, it only shortens the loopable part so it cuts off. If this is the case you should be able to drag that bar to the left to lengthen the looping area, fixing the problem above, however you can not drag it to the left. This essentially makes it a feature that has no apparent benefits.

Note: These problems are in 4.16 however I did not see anything addressing them in the 4.17 notes so I assume they're present there as well.

Product Version: UE 4.16
Tags:
more ▼

asked Sep 27 '17 at 06:03 PM in Bug Reports

avatar image

Juice-Tin
152 38 37 45

avatar image Ridley R ♦♦ STAFF Oct 04 '17 at 04:54 PM

Hi,

Can you send me some screenshots/more details on how you have things(Blueprints, Sequencer, etc.) set up? This way I can work on setting up a repro project. I would also recommend making a copy of your project in 4.16 and updating it to 4.17 to see if the same issue occurs. It may not be directly mentioned in release notes, but some changes may have been made that would indirectly affect the issue. It also could be something that could get included in hotfixes.

-Thank you

avatar image Juice-Tin Oct 05 '17 at 03:18 PM

Hi Riley, it's very simple so I can easily just give a step by step. Also I am on 4.17 now and all bugs are still present.

Animations always play at the rate of 1 1. Throw a skeletal mesh into the scene with animation set to Custom Mode 2. Go into one of it's animations and set play rate to 0.5 3. Put that skeletal mesh into sequencer and set the above animation. It will play at full speed.

Slot Anims play at proper speed but have wrong loops 4. Throw a skeletal mesh into the scene with a new AnimationBlueprint set on it. 5. Set up AnimationBlueprint like this (link) 6. With skeletal mesh on UseAnimBP mode, put it into sequencer and assign that animation from above again. 7. You'll see the animation plays at the proper speed (0.5) but it loops too quickly, at the point it would loop as if it played at 1 speed. 8. Attempt to right click the animation track and change the speed to fix the above.

Scaling the Animation Track Now you can also try scaling the left side of of the animation track to fix the above, and you will again notice some oddities with how that works.

Note: I'm assuming the problem with the first two is an oversight with not matching animations in sequencer to the speed set in the animation. However, slot animations behave as they are (don't blend or anything) which is why the their speed isn't being adjusted, but the actual slot animation still plays exactly how it was set up (at 0.5 speed).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

For the animations playing at a rate of 1, one way to work around this is to go to your sequence and select the animation track itself that you want to change the speed of. If you right click this you will have an option that says properties. In the properties you can change the Play Rate. Changing this setting in the Animation Asset itself will affect it for gameplay, but not in sequencer. In this same Properties box mentioned above, you can also change some other settings as well, such as Start and End time etc. This can change how you loop animations. When it comes to editing some of the speeds and how animations loop, it is better to remain consistent with the work flow since there are several ways to drive your animation(via animation asset, through sequencer, blueprints etc.) It depends and what exactly you are trying to accomplish, but it seems like you may have some of your animations driven a few different ways. This may be causing some settings to conflict/override each other. If you can post a gif/video of of the issues/results you have having from scaling the animation tracks I can take a more thorough look at those as well.

-Thank you

more ▼

answered Oct 09 '17 at 06:33 PM

avatar image

Ridley R ♦♦ STAFF
1.2k 2 4 4

avatar image Ridley R ♦♦ STAFF Oct 17 '17 at 04:06 PM

Hi,

Due to the time that this thread has remained inactive, I will be accepting the comment above as an answer. If you have any questions regarding this thread feel free to reopen it and I will get back to you.

-Thank you

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question