x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

4.18.0 Preview 2 - Blueprints Constantly Crashes on macOS 10.12.6

Unreal Engine is unresponsive and noted as "Application not Responding". I've tried waiting it out, but I always need to force quit the engine.

I've been using it with the new AR nodes/tools.

Seems to happen when:

  • placing a new blueprint of any kind

  • adding ARKit nodes, especially when "breaking" them.

Obviously, I assume it'll become more stable with newer previews, just wanted to share.

Best, David

Product Version: UE 4.18 Preview
Tags:
more ▼

asked Sep 29 '17 at 07:56 PM in Bug Reports

avatar image

davidvjc
1 2 5

avatar image vagrant7 Sep 30 '17 at 04:01 AM

Same problem here, beach balls after 1 task frequently. Sometimes I can't even get a node down. Placing behavior tree tasks is basically impossible. Setting enum name also almost always gives a crash in animBP. Glad to hear it's happening to others though as I was worried it was slow Mac (I imagine others experimenting with ARKit but who normally develop in Windows on a faster PC also might be wondering this).

I have got some stuff working pretty well but I have gone through at least 200 crashes to get there. Specs are mid 2012 Retina w/ 2.6 ghz i7 and NVIDIA GeForce GT 650M 1024 MB, Intel HD Graphics 4000 1536 MB. No problem running the actual scene on iPad, works nice. Hoping for hot fix asap.

avatar image Tim C ♦♦ STAFF Oct 02 '17 at 02:18 PM

Hi,

I tried to get a crash in 4.18.0 Preview 2 using your descriptions, but was unable to do so. This is what I tried.

  • Created a new Actor Blueprint and placed it in the level.

  • Tried using several ARKit-related nodes in the previously created Blueprint.

  • Created a new Behavior Tree and placed several Task nodes.

  • Created a new Anim Blueprint, added a new Enum variable, and changed its name.

None of those resulted in a crash for me. Would it be possible to get the callstack for the crash that you are getting? Also, could you please provide some specific steps that you are following that results in a crash?

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

We have not heard back from you for some time. Are you still having trouble with this? I will be marking this post as resolved for internal tracking purposes, but please feel free to add a comment and re-open the post if you need any additional help.

Tim

more ▼

answered Mar 23 '18 at 07:57 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question