x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Vehicle Wheels Sink through Floor (Collisions Ignored)

My vehicle wheels fall through the floor. I tried:

  • Re-importing the FBX source asset, setting up the physics from scratch

  • Following different tutorials and reading up documentation

  • Contacting a Youtuber who used the same asset pack and followed his step-by-step

The wheels still sink through the floor, their collision is ignored completely in-game. In the physics editor, it collides perfectly. If I drop the car into my scene and simulate, it works fine and the collisions are correct - wheels even spin when the car moves.

The problem starts when: I properly set up the wheels in the vehicle's movement component (naming them, etc. in the correct order).

I've done everything accurately as every tutorial described, even the YouTuber who had used the same assets and got around the same problem and my issue persists.

Help

alt text

Product Version: Not Selected
Tags:
phys3.png (184.7 kB)
more ▼

asked Oct 03 '17 at 01:26 PM in Using UE4

avatar image

Sinn Studio Inc.
6 2 3 4

avatar image pzy64 Jan 15 '18 at 04:18 AM

You might need to increase wheel radius in your Vehicle Wheel blueprint (or UVehicleWheel class)

avatar image Saah88 Mar 18 '18 at 12:54 AM

increasing Wheel size (in BP/C++ class) will not work here, the minimal size is the Mesh's size, not the Class's setting. i replied about it there:

https://answers.unrealengine.com/questions/753411/vehicles-are-completely-broken-by-default.html?childToView=769678#answer-769678

This topic is about different thing, which i today learned how to fix (i posted my answer below).

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hey can you try increasing the uniform scale in your skeletal mesh and then reimporting the mesh using the reimport option on the top in the skeletal mesh editor. This helped me earlier when I faced the same issue. The Unfurom Scale value only seems to reflect when you reimport the mesh.

more ▼

answered Oct 03 '17 at 05:48 PM

avatar image

kodusu
131 3 4 6

(comments are locked)
10|2000 characters needed characters left

you need to apply roation and scale on the wheels and mesh

more ▼

answered Jan 08 '18 at 11:19 AM

avatar image

True Origins Int
57 7 13 22

(comments are locked)
10|2000 characters needed characters left

If you have set everything correctly:

  1. measuring unit "cm"

  2. Joints dont have any rotations (they must be zeroed 0;0;0)

  3. Mesh is oriented as X to Forward (Y to side, Z to up)

  4. Z = up, not Y. Y = side.

then just read my post there:

https://forums.unrealengine.com/development-discussion/content-creation/21359-collision-problem-on-vehicle-model-skeleton-importing-from-maya?p=1445379#post1445379

Otherwise read that whole thread (just 2 pages, until my post).

I have solved exactly same issue, so i know what i link.

more ▼

answered Mar 18 '18 at 01:27 AM

avatar image

Saah88
36 4 9

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question