Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor crash when launching project to Android device

The editor crashes almost instantly when I press the launch button to an Android device. This seems to occur on any project and version of UE, so I tried to reinstall the android sdk but still no luck.

Checking the log file there seems to be some .dll files missing but not sure if it is relevant. But it does show OutputDevice: Errors, which looks like a problem.

link to Log file

Just to simplify things this log file is from an example template called "Rolling" Set to Mobile/Tablet, Scalable 3D or 2D, with no Starter Content. It works on PC Windows 10 fine, so only problems with attempting to launch to Android device via usb.

Appreciate any help with this, thanks.

Product Version: UE 4.17
myproject11.log (62.5 kB)
more ▼

asked Oct 10 '17 at 05:19 PM in Bug Reports

avatar image

13 2 3 6

avatar image Thomas G ♦♦ STAFF Oct 11 '17 at 06:48 PM

Hello Peter,

I was unable to reproduce your issue on our end. I have a couple of questions to help narrow down the issue you are experiencing.

  1. What android device are you deploying to?

  2. Does this occur with a blank project?

  3. What android version is the device your using operating on?

  4. Can you post the callstack from the crash?



avatar image Peter_M Oct 11 '17 at 09:35 PM

Hello Thomas,

Thanks for your response

  1. The android device I am deploying to is a Oukitel K4000 Pro. Has 2GB of Ram with MTK6735P quad-core processor.

  2. Same problem occurs with a blank project.

  3. Android version is 5.1

  4. How do I post the callstack from the crash?

I should note that I can "Package Project" for android then install it to the phone manually and it would work. It's only when I press the "Launch" button that causes the editor to crash.

avatar image Thomas G ♦♦ STAFF Oct 12 '17 at 08:12 PM

The callstack should be in a window that appears when the editor crashes. Is this occurring on any other android device for you?



avatar image Peter_M Oct 13 '17 at 09:49 PM

I don't think I see that window but I do get this message box as soon as it crashes.

alt text

I don't have another working android device at this time, but I'll see what I can do to test that.

ue.png (104.3 kB)
avatar image Thomas G ♦♦ STAFF Oct 17 '17 at 03:46 PM

Hello Peter,

Do you get this same error when using out 4.18 Preview build of our engine?


avatar image Peter_M Oct 17 '17 at 09:50 PM

Hello Thomas,

I installed 4.18 Preview version on a different ssd this time and it still ended up with the same problem as soon as the "Launch" button is clicked.

avatar image Ferox Oct 17 '17 at 10:42 PM

And i have this problem i cant find answer :/ Im using UE4 4.17 and i make a new third person project for mobile. I do all what i see in the [Android Quick Start] and i actualy canot launch fo my phone coz UE4 not respond and crush. After that i try package for android, and i got "PackagingResults: Error: Unknown Cook Failure". Really i don't know how fix this I'm looking three days and nothing..

avatar image Peter_M Oct 18 '17 at 11:24 AM

Hello Ferox,

I think the [Android Quick Start] has some typos which will not make it work. Instead of installing for "1R6" try installing "CodeWorks for Android 1R6u1" and then relink that back to the editor project settings as the Quick Start shows. You should then be able to package it with no cook errors.

avatar image Ferox Oct 18 '17 at 05:54 PM

Yes i instal "CodeWorks for Android 1R6u1" and have that eror problem. For "1R6" i don't know, but in the [Android Quick Start] it is written to choose 1R6u1. And this not working.

avatar image Ferox Oct 18 '17 at 10:34 PM

I packedge android project for: ATC, DXT, ETC1, ETC2, PVRTC formats. But error is in the ASTC and when i package my project to all i got that error.

avatar image Peter_M Oct 20 '17 at 04:10 PM

Hello Thomas,

I was able to test this on another PC to the same android device and the editor was running normally with no crashing when the "Launch" button is clicked. So I now know it is a local issue with my work PC and will try find out what has changed.

So far I know just reinstalling UE4 does not seem to reset things.


avatar image Thomas G ♦♦ STAFF Nov 09 '17 at 05:07 PM

Hello again Peter_M,

Could you provide the DxDiag for the machine where the issue occurs?


avatar image Peter_M Nov 10 '17 at 06:10 PM

Hello Thomas,

I'm not near the machine at this time but will be able to send the DxDiag info next Monday.

I'm wondering if it's an access permissions issue on the android device, is there a way to check if it has somehow blocked the PC?


avatar image Peter_M Nov 13 '17 at 07:13 PM

Ok here is the DxDiag info attached, DxDiag


dxdiag.txt (79.0 kB)
avatar image Thomas G ♦♦ STAFF Dec 11 '17 at 07:24 PM

Hello Peter,

Are you still encountering this issue?


avatar image Peter_M Dec 12 '17 at 01:58 AM

Hi Thomas,

Yes, although I tried 'Revoke USB debugging authorisations' on the android device before connecting it to the PC and when launched it somehow worked once on a test project. It ran the whole compiling process and got into the phone without crashing. But when I tried to Launch again it just kept failing after that.

So unfortunately I still have this problem.

avatar image Peter_M Dec 12 '17 at 04:45 PM

Ok to follow up it looks like I can get it working via 'Project Launcher' window and check the 'Advanced' button to change Data builds.

There seems to be issues cooking with Android_ASTC when Data Build is set to "On the fly" and crashes when it gets to "LogTexture: Display: Building textures: WhiteSquareTexture (ASTC_RGBAuto, 32x32)". Despite that crash the editor is still able to run and completes the build.

At the point where it crashed I managed to save a log which i think points to a "fatal" error to do with NetworkPlatformFile.cpp at line 3471. See the log: attached

ETC1 or ETC2 seem to be fine if set to "By the book" but issues with ASTC gets included when set to "On the fly".

So the Launch button I use to find so convenient is still busted but I can get it to run from 'Project Launcher' window normally as long as I avoid ASTC settings. It does seem to take longer though.

I hope this info is a bit more useful.


avatar image Dania_shl Nov 14 '17 at 09:39 AM

Hello peter

I have same problem with UE4.14 and 4.18. Please let me know if you have or had "BlueStacks" or any other android emulator in your PC?

In UE4.4 (I am not sure) the editor didn't recognize my device even when I removed the BlueStacks. I solved the problem by reinstalling my Windows. At this time I removed BlueStacks and after that I installed UE4.18 and CodeWorks for Android 1R6u1, the editor crash same as you mentioned, I am not sure but I am putting the blame on BlueStaks.

avatar image Peter_M Nov 17 '17 at 04:21 PM

Hello Dania,

I haven't used BlueStacks, but may have had a different emulator installed for android testing I think before I moved on to Unreal 4. Still Unreal launching to Android was working normally on my PC when I first used it.

At this time with UE 4.18 and other versions it has always recognized the Android device that I use for testing but still crash the editor on Launch.

Ideally I would like to avoid reinstalling windows...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first


We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.


more ▼

answered Dec 26 '17 at 05:44 PM

avatar image

Thomas G ♦♦ STAFF
7k 64 4 54

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question