x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Engine 4.12.5 on mac osx Crash when Loading the editor

When I load UE4 editor version 4.12.5 on my MacBook it immediately crashes with this message:-

MachineId:838A1BD4F946B91FB6F3BABE3F7D6CDF EpicAccountId:d56a26a64b3b46d29821d21f12fd4714

SEGV_NOOP at 0x0

SLSNewWindowWithOpaqueShape Address = 0x7fff6bb28c49 (filename not found) [in SkyLight] -[_NSCGSWindow initWithConnectionID:] Address = 0x7fff4862a13e (filename not found) [in AppKit] +[NSCGSWindow(NSCGSWindowCreation) windowWithConnectionID:] Address = 0x7fff4862908c (filename not found) [in AppKit] _NSCreateWindowWithOpaqueShape2 Address = 0x7fff47d29bc3 (filename not found) [in AppKit] -[NSWindow _commonAwake] Address = 0x7fff47d288b3 (filename not found) [in AppKit] -[NSWindow _commonInitFrame:styleMask:backing:defer:] Address = 0x7fff47b69ea0 (filename not found) [in AppKit] -[NSWindow initContent:styleMask:backing:defer:contentView:] Address = 0x7fff47b686d7 (filename not found) [in AppKit] -[NSWindow initWithContentRect:styleMask:backing:defer:] Address = 0x7fff47b6818e (filename not found) [in AppKit] invocation function for block in FMacPlatformSplash::Show() Address = 0x10880a117 (filename not found) [in UE4Editor-Core.dylib] invocation function for block in PerformBlockOnThread(FCocoaRunLoopSource&, void () block_pointer, NSArray*, NSString*, bool) Address = 0x1087c2250 (filename not found) [in UE4Editor-Core.dylib] FCocoaRunLoopSource::Process(_CFString const*) Address = 0x1087d5530 (filename not found) [in UE4Editor-Core.dylib] -[FCocoaRunLoopSourceInfo perform] Address = 0x10878e576 (filename not found) [in UE4Editor-Core.dylib] Unknown() Address = 0x7fff4a55a6c1 (filename not found) [in CoreFoundation] Unknown() Address = 0x7fff4a6142cc (filename not found) [in CoreFoundation] Unknown() Address = 0x7fff4a53d160 (filename not found) [in CoreFoundation] Unknown() Address = 0x7fff4a53c5dd (filename not found) [in CoreFoundation] Unknown() Address = 0x7fff4a53be43 (filename not found) [in CoreFoundation] RunCurrentEventLoopInMode Address = 0x7fff4985b866 (filename not found) [in HIToolbox] ReceiveNextEventCommon Address = 0x7fff4985b5d6 (filename not found) [in HIToolbox] _BlockUntilNextEventMatchingListInModeWithFilter Address = 0x7fff4985b354 (filename not found) [in HIToolbox] _DPSNextEvent Address = 0x7fff47b589f7 (filename not found) [in AppKit] -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] Address = 0x7fff482edd98 (filename not found) [in AppKit] -[NSApplication run] Address = 0x7fff47b4d805 (filename not found) [in AppKit] tchar_main(int, wchar_t**) Address = 0x1085653ca (filename not found) [in UE4Editor] main Address = 0x108564c3e (filename not found) [in UE4Editor] start Address = 0x7fff71a9d145 (filename not found) [in libdyld.dylib]

Here are my Laptop Specs:- macOS High Sierra V10.13 MacBook Pro (Retina, 13 inch, early 2015) Processor 2.7GHz intel core i5 Memory 8GB 1867 MHz DDR3 Graphics Intel Iris 6100 1536 MB

Product Version: UE 4.12
Tags:
more ▼

asked Oct 10 '17 at 07:06 PM in Using UE4

avatar image

A_Ali107
6 2 3 5

avatar image David Zapata B Dec 05 '17 at 10:30 AM

Same issue here. I tried the version 4.18.1 as well, but this time it takes forever to "compile shaders" and uses all my CPU.

Using: MacBook Pro (Retina, 15-inch, Mid 2015)), 2.8 GHz Intel Core i7 (4 cores), 16 GB 1600 MHz DDR3, AMD Radeon R9 M370X 2 GB, Intel Iris Pro 1536 MB.

Given the download size is so big, I am hesitating now to download any other version of Unreal Engine 4.

avatar image pcerioli Jan 27 '18 at 08:04 PM

Same issue here. Since I upgraded to 4.18, I cannot open the Unreal Editor for 4.7, 4.8. 4.9. 4.10. However, I can open the Unreal editor for 4.16, 4.17, 4.18 I haven't tried the intermediate versions yet... but something has changed with 4.18

Log:

[2018.01.27-00.36.28:362][ 0]LogMac: === Critical error: === SIGSEGV: invalid attempt to access memory at address 0x0

[2018.01.27-00.36.28:362][ 0]LogMac: SLSNewWindowWithOpaqueShape() Address = 0x53913485 (filename not found) [in SkyLight] HIMenuBarView::DrawSelf(short, __HIShape const*, CGContext*) Address = 0x312c88c1 (filename not found) [in HIToolbox] HIMenuBarView::DrawWithoutCustomization(short, __HIShape const*, CGContext*) Address = 0x312c83c2 (filename not found) [in HIToolbox] HIMenuBarView::DrawingDelegateHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) Address = 0x312c835a (filename not found) [in HIToolbox] DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) Address = 0x312ac814 (filename not found) [in HIToolbox] SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) Address = 0x312abb5d (filename not found) [in HIToolbox] SendEventToEventTargetWithOptions() Address = 0x312ab9d3 (filename not found) [in HIToolbox]

Here are my Laptop Specs:-

macOS High Sierra V10.13.3 MacBook Pro (Retina, 15-inch, Mid 2014) 2.5 GHz Intel Core i7 Memory: 16 GB 1600 MHz DDR3 Graphics: NVIDIA GeForce GT 750M 2 GB, Intel Iris Pro 1536 MB

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I have the same issue. Did you ever find a solution?

more ▼

answered Jan 10 '18 at 06:42 PM

avatar image

pulsenoir
1 1

avatar image giupo Jan 12 '18 at 08:57 PM

I've switched to Unity3D. I didn't want to, but I had no choice...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question